1

I want to run chrome thought incognito so I added

Exec=/usr/bin/google-chrome-stable --incognito

to the .desktop file. This has, up until now, done what I wanted. Now, it opens regularly and even when I rename the file chrome is still able to open normally.

Any ideas how to fix it?

I am running Kubuntu 16.04.1

15
  • Hi @HanMah, which .desktop file did you edit? in /usr/share/application or a local copy in ~/.local/share/applications Jan 8 '17 at 7:34
  • ...Anyway, most likely, a local .desktop file exists, overruling the global one. Good practice is to copy a .desktop file locally, edit that one, log out and back in. Please mention the situation, so we can provide this question an answer. Jan 8 '17 at 8:22
  • @chaskes I used a graphic editor (sudo kate) what is wrong with that? I renamed it to del.desktop and then successfully opened chrome. I am still a beginner with linux but I would assume that if chrome was using that desktop file to open then it would not work after the change. I double checked that I spelled it corectly
    – HanMah
    Jan 8 '17 at 12:03
  • @JacobVlijm /usr/share/applications/ can you explain what you are suggesting that I do?
    – HanMah
    Jan 8 '17 at 12:03
  • I don't know if this is important information but I open chrome through the plasma search
    – HanMah
    Jan 8 '17 at 12:05
2

I would like to let everyone know how I solved this issue. But first I would like to thank @JacobVlijm for their amazing help. I don't have that much technical skills so I may be butchering the explanation. Please correct me if I am explaining it incorrectly.

So apparently there are 2 google-chrome.desktop files. One is saved in /usr/share/applications and that is the "main one". And one is saved in /home/yourname/.local/share/applications and that is the local one. I changed the main one before and I was told not to do that but rather only change the local one. The second issue was that in the . desktop file there are 3 instances of Exec=/usr/bin/google-chrome-stable. I changed only the last one. In order to fix the issue, I changed all three, and now it works.

1
  • That's why I asked to post the (local) .desktop file. If there where no other local copies, it had to be an issue with the file. :). Only the first Exec= line is relevant in this case though. Glad it worked out. Jan 10 '17 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.