3

I recently upgraded my server from Ubuntu 14.04 to Ubuntu 16.04, but the phpmyadmin version is still 4.5, while I want to install 4.6 (for support of the new JSON type).

The common instructions I find online is to add the repository nijel/phpmyadmin via apt-add-repository, but this gives me a strange bug.

root@myserver:~# add-apt-repository ppa:nijel/phpmyadmin
 Latest phpMyAdmin packages - https://www.phpmyadmin.net/. Based on packages available in Debian.

There are some notable changes:

* it currently requires updated PHP packages, you can get packages from https://launchpad.net/~ondrej/+archive/ubuntu/php/
* it does include embedded copies of PHP libraries

If you like phpMyAdmin, you can support it's further development at https://www.phpmyadmin.net/donate/ or https://www.phpmyadmin.net/sponsors/, thanks!
 More info: https://launchpad.net/~nijel/+archive/ubuntu/phpmyadmin
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp9zj2r1n2/secring.gpg' created
gpg: keyring `/tmp/tmp9zj2r1n2/pubring.gpg' created
gpg: requesting key 06ED541C from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp9zj2r1n2/trustdb.gpg: trustdb created
gpg: key 06ED541C: public key "Launchpad PPA for Michal \xc4\x8ciha\xc5\x99" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
    self.run()
  File "/usr/lib/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 688, in addkey_func
    func(**kwargs)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 401, in add_key
    return apsk.add_ppa_signing_key()
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 271, in add_ppa_signing_key
    tmp_export_keyring, signing_key_fingerprint, tmp_keyring_dir):
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 220, in _verify_fingerprint
    got_fingerprints = self._get_fingerprints(keyring, keyring_dir)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 212, in _get_fingerprints
    output = subprocess.check_output(cmd, universal_newlines=True)
  File "/usr/lib/python3.5/subprocess.py", line 626, in check_output
    **kwargs).stdout
  File "/usr/lib/python3.5/subprocess.py", line 695, in run
    stdout, stderr = process.communicate(input, timeout=timeout)
  File "/usr/lib/python3.5/subprocess.py", line 1059, in communicate
    stdout = self.stdout.read()
  File "/usr/lib/python3.5/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 96: ordinal not in range(128)

this looks like a bug in the ppa software, but I'm lost on how to solve this.

2

I found a solution. Apparently it's a system localisation problem. I ran

sudo locale-gen en_US.UTF-8
export LANG=en_US.UTF-8

and the ppa could be used without any problem.

| improve this answer | |
  • Ah yes, should have realized that myself :D – Rinzwind Jan 7 '17 at 20:56
1

Try again? It might be fixed since I get this:

$ sudo add-apt-repository ppa:nijel/phpmyadmin
[sudo] password for rinzwind: 
 Latest phpMyAdmin packages - https://www.phpmyadmin.net/. Based on packages available in Debian.

There are some notable changes:

* it currently requires updated PHP packages, you can get packages from https://launchpad.net/~ondrej/+archive/ubuntu/php/
* it does include embedded copies of PHP libraries

If you like phpMyAdmin, you can support it's further development at https://www.phpmyadmin.net/donate/ or https://www.phpmyadmin.net/sponsors/, thanks!
 More info: https://launchpad.net/~nijel/+archive/ubuntu/phpmyadmin
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpzsijcqvx/pubring.gpg' created
gpg: /tmp/tmpzsijcqvx/trustdb.gpg: trustdb created
gpg: key 80E7349A06ED541C: public key "Launchpad PPA for Michal Čihař" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1
OK

See the name? I get Čihař Where you got \xc4\x8ciha\xc5\x99. So it is an encoding/decoding problem of a none-ASCII character.

If it does not work report it on his launchpad page: https://launchpad.net/~nijel/+archive/ubuntu/phpmyadmin

| improve this answer | |
  • No, still there. What version of add-apt-repository are you using? It feels like this a bug in the handler rather than in his code. If you're running a more recent version (e.g. in Ubuntu 16.10) it may already be fixed for you. Anyway, I'll let him know. – user1111929 Jan 7 '17 at 20:27
  • Some googling after your input helped me solve the problem, see other post. Thanks! – user1111929 Jan 7 '17 at 20:31
1

In response to your question, I added the PPA and ran it to see what would happen. In running it, I did receive a bunch of error messages. But then the Ubuntu software update popped-up by itself and I ran it. That updated phpMyAdmin to 4.6.5.2deb1+deb.cihar.com~xenial.3

However, that resulted in the following warning: "The secret passphrase in configuration (blowfish_secret) is too short."

To resolve that issue, you need to modify the file: /var/lib/phpmyadmin/blowfish_secret.inc.php.

 <?php
// $cfg['blowfish_secret'] = 'U0v9kMkdKICvsc6NYgfqryAu';
// modified 1/7/2017
// http://serverfault.com/questions/615550/phpmyadmin-error-the-configuration-file-now-needs-a-secret-passphrase
$cfg['blowfish_secret'] = 'mrgQxxk8C-y}U7ji2BO9o5jLf}Qhe-BI[~6SUa';

phpMyAdmin now loads without any warning message.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.