0

Here is the setup:

  • I have integrated audio on my mother board, onto which my speakers are connected by a 3.5mm jack
  • I have a video card with HDMI output (Radeon HD 5700 Series), but I use the DVI ports, not HDMI. So no sound this way really
  • I have a USB headset with microphone.

Problem summary:

  • when logged in, in Settings > Sound > Output , I only have HDMI / DisplayPort and the Headphones. The sound works via headphones, but I do not have any actual audio device on the HDMI. So my speakers do not get any sound.
  • on boot, the startup sound does play via the speakers (I can hear the drum like sound!).

All 3 devices are detected:

pacmd list-cards | grep alsa.long_card_name
        alsa.long_card_name = "HDA ATI HDMI at 0xfbcfc000 irq 32"
        alsa.long_card_name = "HDA Intel MID at 0xfbbf8000 irq 31"
        alsa.long_card_name = "Logitech Logitech USB Headset at usb-0000:00:1d.0-1.6, full speed"

And:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: VT1828S Analog [VT1828S Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 2: VT1828S Alt Analog [VT1828S Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 3: VT1828S Digital [VT1828S Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

So the question really is, how can I add the built-in audio (with my speakers) to the Settings > Audio > Output list?

The Built-in Audio is seen in pavucontrol but the profile doesn't seem right. I tried changing it to Analogue Stereo Output but it doesn't seem to work and removes the Built-in Audio entry from "output devices"

Some screenshots to help: Volume Control - Configuration Volume Control - Output Devices

1
0

Using the link provided by Elder Geek, non validated answer worked for me:

I added the below to /etc/pulse/default.pa (well uncommented the line with load-module module-alsa-sink and added the device bit) load-module module-alsa-sink device=hw:0,0

Then restarted the system, after which the Built-in audio was present in Settings > Sound! Selecting it made it work...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.