3

The cursor keeps jumping on my Ubuntu 16.04. The solution described in "Disable Touchpad while typing option" gone in Ubuntu 16.04 LTS requires giving the syndaemon command. This works for me but I have to keep giving this command everytime I start my system ( Dell Inspiron 25, 7000 series). Is there any permanent solution to do this (any check box I can tick somewhere ??)

3
  • Hi Ubkash, it can be solved adding a command to startup applications, but with a small break to prevent overruling by local procedures. It is a dupe, will find in a minute... – Jacob Vlijm Jan 7 '17 at 19:08
  • ...or you could try the answer by Pilot? Please mention if it works. – Jacob Vlijm Jan 7 '17 at 19:09
  • See: askubuntu.com/questions/568090/… – Jacob Vlijm Jan 7 '17 at 19:13
3

You can do it by installing libinput. It has mush better palm detection and disable while typing algorithm.

Run in terminal

sudo apt install xerver-xorg-input-libinput

Then run

sudo -H gedit /usr/share/X11/xorg.conf.d/90-libinput.conf

and add

Option "Tapping" "true"

to the touchpad section.

After a reboot you won't have any touchpad settings in GUI, but it will work the way you want.

4
  • @sudodus There is no need to add universe it is in the default Ubuntu. – Pilot6 Jan 7 '17 at 19:06
  • @sudodus Please stop editing my answer. You can always write your own. – Pilot6 Jan 7 '17 at 19:10
  • At least in Ubuntu 16.04.1 LTS live, which I am running to test your good answer, it is necessary to add universe. I think it means that it is also necessary in Ubuntu persistent live. Otherwise libinput is not found. (I only wanted to help, but I will try to remember to stay away from your answers.) – sudodus Jan 7 '17 at 19:15
  • Live is a different story. – Pilot6 Jan 7 '17 at 19:15
2

Install touchpad-indicator. It'll put an icon in your top panel, and is fully configurable via a GUI. It actually uses syndaemon under the skin.

For more information, see http://tipsonubuntu.com/2014/05/26/install-touchpad-indicator-ubuntu-14-04/. From that site:

sudo add-apt-repository ppa:atareao/atareao 
sudo apt-get update
sudo apt-get install touchpad-indicator

The software can also be found at https://launchpad.net/~atareao/+archive/ubuntu/atareao and https://launchpad.net/touchpad-indicator.

0
1

syndaemon(1) does not have a configuration file or way to autostart itself. You can treat it like any normal program or script which needs to be autostarted.

The simplest method is to modify your crontab(5) and use the @reboot alias.

Or you can follow the more graphical way.

Reference:

0

It works for me to do it via the graphical user interface.

  1. Click on the icon with the cog wheel and wrench

  2. In the System Settings window, Click on 'Mouse and Touchpad'

  3. In the Mouse and Touchpad window, click on the switch icon at the right side. You will see that it switches from 'ON' to 'OFF'

  4. That's it. You can close the window, and Ubuntu will remember the setting (unless it is a live-only system that cannot remember anything).


If you don't want the touchpad completely off, you can turn off only 'tap to click' and 'two finger scrolling' and leave the switch on the right side 'ON'.


If you are not satisfied with the suggestions above, you can put the command that works for you (with syndaemon) into 'autostart' according to the following link,

How do I start applications automatically on login?

2
  • This seems to be explaining how to disable the touchpad entirely. Does "Mouse and Touchpad" in System Settings also include an option to disable the touchpad just while text is being entered, but have it otherwise enabled? Judging from the OP's question title, linked question, and use of syndaemon, that's what the OP is looking for. (I'm not asking this rhetorically; I don't have any Unity or GNOME based Ubuntu systems set up currently -- I mainly use Lubuntu -- and I don't know if there's a setting for this in "Mouse and Touchpad." If so, you might want to add details about it.) – Eliah Kagan Jan 7 '17 at 18:12
  • I booted a live Ubuntu 16.04.1 LTS, and performed the actions, that I recommend. There is no option, that does exactly what the OP wants. It would be an option to recommend to put the command, that obviously works, into 'autostart', but it is more complicated. – sudodus Jan 7 '17 at 18:17
0

This can work around as part of the solution: while read line; do if [[ $line == "Touchpad" ]]; then tid="$(echo $line | cut -d'=' -f2 |cut -c1-2)"; xinput set-prop $tid "Device Enabled" 0; fi; done < <(xinput list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.