I've installed ubuntu 16.04 LTS, removing windows 7, through bootable pen. Everything went well during installation. With ubuntu already running, after doing all the updates, most of the times, after a while my touchpad and keyboard freezes. First, I'm unable to click anywhere but can move mouse, no keyboard working. Then, mouse freezes completlty.

Tried the solution displayed at: Touchpad stops working after a while, Ubuntu 14.10, Dell Latitude E7440

rm -rf /etc/modprobe.d/blacklist_i2c_hid.conf

And at: Proper touchpad thumb & palm detection with libinput

sudo apt-get install xserver-xorg-input-libinput
sudo apt-remove xserver-xorg-input-synaptics

Then added some configurations

sudo vi /usr/share/X11/xorg.conf.d/90-libinput.conf 

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "Tapping" "True"
    Option "DisableWhileTyping" "True"

Still, after this, it froze again. All I can do is force shutdown.

Anything else I can or should do?

  • Update: Re-Installed 16.04, this time didn't do any updates and after a while it froze again. – Nuno Monteiro Jan 7 '17 at 14:02

It was the graphics driver - i installed nvidia and works like a champ now (same issue, same pc)

Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics

basically -


to get into shell that won't get hosed when things freeze up


sudo apt-get install nvidia-375

  1. sudo gedit /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"

  1. sudo bash -c 'echo -1 > /sys/module/usbcore/parameters/autosuspend'

  2. sudo nano /lib/udev/rules.d/60-persistent-v4l.rules

SUBSYSTEM=="usb", ATTRS{idVendor}=="04f2", ATTRS{idProduct}=="b36e" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

4.cp /lib/udev/rules.d/60-persistent-v4l.rules /etc/udev/rules.d/

5.sudo nano /etc/rc.local

sudo sh -c "echo USB0 > /proc/acpi/wakeup" sudo sh -c "echo USB1 > /proc/acpi/wakeup" sudo sh -c "echo USB2 > /proc/acpi/wakeup" sudo sh -c "echo USB3 > /proc/acpi/wakeup" sudo sh -c "echo enabled > /sys/bus/usb/devices/3-1/power/wakeup"

=============also, get a usb powered hub, put the mouse on that.

  • each sudo comment on its own line – mindtab Jan 22 '17 at 16:41
  • also, might try the 'mate' desktop... wiki.mate-desktop.org/download – mindtab Jan 22 '17 at 17:02
  • thanks. I'm going to be honest, after several days of searching trough the web I found out how to solved, but after trying so many things, don't actually remember which one worked... dumb me, I know. Thanks anyway. Btw, I still have an unrelated issue with the installation, if I suspend or close my laptop, when open it back, or wake it, it starts to get slower and slower... reboot solves it. So right now, I never suspend my laptop. When I want to close, need to turn it off and turn it on. – Nuno Monteiro Jan 26 '17 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.