1

I am running a fresh install of Ubuntu 16.04 (alongside Windows 10) on a brand new(ish) Toshiba laptop. Everything was working fine until I installed Bioshock Infinite from Steam and when I ran it I got an error saying that my graphics driver did not support OpenGL 4.1. My graphics card is Nvidia 930M.

So I did a search and found this post: Steam and OpenGl 4.1. I followed the instructions there and installed the repository ppa: oibaf/graphics-drivers.

After the restart all menus were simply black rectangles, the Terminal window was completely black and there were large black borders around windows. This problem appears on several other posts. I followed all of the instructions in these (such as remove Nvidia and reinstall, remove the above repository, etc.). But to no avail. I am also surprised how little help this problem has received from the community. (See for example: Black border in all menus and black terminal after installing Katoolin).

2

I am happy to say that by installing the latest Nvidia drivers I solved the problem. Here's what I did.

I followed the instructions from here to find and install the latest driver for Nvidia.

I then went into system settings -> software&updates -> additional drivers and selected the latest proprietary Nvidia driver I just installed and clicked apply changes. At this point a black dialog box comes up asking for your password. Just blindly enter your password and press enter. Then restart.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.