My Nexus 5X died on Tuesday night. I bought a brand new Galaxy S7; it arrived today. The USB tethering does not work. Tethering from my N5X worked flawlessly. I have not made any changes to my computer.

After connecting the cable and activating the USB tether on the S7 I see the SAMSUNG ethernet connection in my list of networks. It is disconnected and stays greyed out. Ifconfig doesn't show the connection.

Does anyone have any ideas of what the problem could be? Thank you for your time.


Your service provider may have disabled tethering on the device.

You can see if this is the case by downloading one of the tethering apps from the Google Play store and attempting to enable tethering with it.

If you can enable tethering with an "App" but not with the built-in native Android or Samsung software then tethering is disabled by the phone company.


I got tethering to work on a different Linux distro, but I believe the same method I used will apply to Ubuntu because it's all done through the command line.

First, install macchanger. It should be in your repositories. It allows you to change the MAC address of an interface. I found out my problem was coming from the phone giving a MAC address of 00:00:00:00:00:00 when tethering was enabled and the computer couldn't work with that. After installing macchanger, type the following commands, substituting eth1 with what your computer calls the interface from the phone:

macchanger -r eth1
ifconfig eth1 up
dhclient eth1

You may need to use sudo for the commands to work. If you don't have dhclient on your computer, typing dhcpcd eth1 should work.

You should now be able to access the internet through the tethered connection. You will have to do these steps every time you want to connect.

  • Specifying the MAC address works for me only when I keep the vendor bytes, i.e. sudo macchanger -a eth1 – Antony Oct 9 '17 at 17:03

Add a new udev rule into /etc/udev/rules.d/local.rules that reads as:

ACTION=="add", SUBSYSTEM=="net", ENV{INTERFACE}=="eth2", RUN+="/usr/bin/macchanger -r eth2", OPTIONS="last_rule"

This will allow you to, automatically, assign a MAC number to the Galaxy S7 when you tether via the USB port. Note, journalctl -F will tell you the correct ethernet (eth2 here) number.

  • IDK why, but the above didn't work for me. After stumbling my way through udev (which I'm not very knowledgeable about), I realized that changing "add" to "move" worked. I'm not sure why, but one can add both version of the rule to the same file. – TSJNachos117 Oct 1 '19 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.