2

I just installed XnView MP version 0.83 from official site Linux DEB 64bit package. But the program cannot start. The error is the following:

/opt/XnView/XnView: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory

I googled the problem and I found the following. One proposed solution is:

sudo add-apt-repository ppa:dhor/myway

but there is no version of this PPA for my version of Ubuntu:

aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Ubuntu/zesty

Another proposed solution is:

apt install libgstreamer-plugins-base0.10-0

But this package is missing for my version of Ubuntu. There is newer version of the package libgstreamer-plugins-base1.0-0 which I had already installed.

I tried to create symbolic link with the name of the missing SO file referring the newer version.

sudo ln -s /usr/lib/x86_64-linux-gnu/libgstapp-1.0.so.0 /usr/lib/x86_64-linux-gnu/libgstapp-0.10.so.0

But now another SO file is missing:

/opt/XnView/XnView: error while loading shared libraries: libgstinterfaces-0.10.so.0: cannot open shared object file: No such file or directory

I cannot find newer version of this file on my computer and I don't know from which package to install it.

Is it possible some kind of workaround to run XnView on my system?

2

I guess you are talking about XnViewMP 0.83 and not XnView 1.73. This is how I got 64-bit version of XnViewMP 0.83 working after downloading it from the link you have provided (you can just copy and paste these commands after you have installed the .deb package):

cd /tmp/
wget http://mirrors.kernel.org/ubuntu/pool/main/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1ubuntu1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb
dpkg -x libgstreamer0.10-0_0.10.36-1ubuntu1_amd64.deb libgstreamer0.10-0_0.10.36-1ubuntu1_amd64
dpkg -x libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb libgstreamer-plugins-base0.10-0_0.10.36-1_amd64
sudo cp -av libgstreamer0.10-0_0.10.36-1ubuntu1_amd64/usr/lib/x86_64-linux-gnu/* libgstreamer-plugins-base0.10-0_0.10.36-1_amd64/usr/lib/x86_64-linux-gnu/* /opt/XnView/lib/
rm -rf libgstreamer-plugins-base0.10-0_0.10.36-1_amd64* libgstreamer0.10-0_0.10.36-1ubuntu1_amd64*

Above commands will download and put all needed libraries to XnViewMP lib folder.

I think this can be considered a bug, since XnViewMP shouldn't require libraries which do not exist anymore.

  • The final copy command seems wrong. – bobeff Jan 6 '17 at 16:30
  • And to me it seems good. I just checked again and it worked as expected for me. If it does not for you, please say what exactly is not working for you. – Lissanro Rayen Jan 6 '17 at 17:06
1

You can get XnView from the GetDeb repositories, which provide the xnviewmp package in version 0.83-1~getdeb1 at the time of writing, including a build for 16.10.

To set up the GetDeb Apps repository as software source for your 16.10 (Yakkety) system, run these two commands:

sudo tee /etc/apt/sources.list.d/getdeb-apps.list <<< 'deb http://archive.getdeb.net/ubuntu yakkety-getdeb apps'
wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

Then update your package lists:

sudo apt update

Now you can install XnView by simply running:

sudo apt install xnviewmp
  • I did the steps you described but there is an error: The following packages have unmet dependencies: xnviewmp:i386 : Depends: xnviewmp-data:i386 (= 0.83-1~getdeb2~yakkety) but it is not installable. I successfully performed sudo apt install xnviewmp-data but the error is still present. – bobeff Jan 6 '17 at 14:49
  • Uh oh. This seems to me like a packaging bug. Either there is only one xnviewmp-data package for all architectures, then the xnviewmp:i386 should depend on that one instead of the nonexistent xnviewmp-data:i386, or they simply forgot to provide the data package for 32 bit. Sorry then, the only thing you can (and should) do here is probably to contact GetDeb and/or file a bug report. See getdeb.net/contact – Byte Commander Jan 6 '17 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.