3

I recently purchased an AOC e1759Fwu USB monitor. I installed the latest DisplayLink Ubuntu drivers via the DisplayLink website (driver 1.2.65). Did a lot of troubleshooting, but I still cannot get the monitor to work. I booted into Windows and installed the drivers and the monitor works fine. When plugging in the monitor I get an initial start flash which shows the AOC logo, then the screen goes black.

Running: lsusb -d 17e9:

Bus 002 Device 005: ID 17e9:ff0d DisplayLink

So it seems like it recognizes the device. I have a GTX960m GPU in this laptop (Asus k501U), but due to Nvidia-Prime I run the X.Org X server - Nouveau display drivers and my current GPU is listed as Intel® HD Graphics 520 (Skylake GT2).

When I run dmesg I can see:

[  273.849409] usb 2-4: new SuperSpeed USB device number 4 using xhci_hcd
[  273.866737] usb 2-4: New USB device found, idVendor=17e9, idProduct=ff0d
[  273.866750] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  273.866758] usb 2-4: Product: E1759Fwu
[  273.866764] usb 2-4: Manufacturer: DisplayLink
[  273.866770] usb 2-4: SerialNumber: KGDG7JA002016

The install log: sudo ./displaylink-driver-1.2.65.run

Verifying archive integrity... All good.
Uncompressing DisplayLink Linux Driver 1.2.65  100%  
DisplayLink Linux Software 1.2.65 install script called: install
Distribution discovered: Ubuntu 16.04.1 LTS
Installing
Configuring EVDI DKMS module
Registering EVDI kernel module with DKMS
Building EVDI kernel module with DKMS
Installing EVDI kernel module to kernel tree
EVDI kernel module built successfully
Installing x64-ubuntu-1604/DisplayLinkManager
Installing libraries
Installing firmware packages
Installing license file
Adding udev rule for DisplayLink DL-3xxx/5xxx devices

My Linux experience is intermediate at best, but everything points to this working correctly. My only thought is that maybe the driver is not starting and I am not sure how to check to see what drivers are currently running. Does anyone have any advice on how to get this working? The reviews and answered questions on Amazon mention it working with Ubuntu.

Following the directions on DisplayLink's site I saw this install log: DisplayLink Install

It shows Starting DLM upstart job

displaylink start/running, process 3397

However my install never gets past

Adding udev rule for DisplayLink DL-3xxx/5xxx devices

  • Have you checked the System Settings > Displays ? The external DisplayLink device should be there but may not be active. And yes, as the reviews say, it works in Ubuntu. – user589808 Jan 10 '17 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.