2

terminal.integrated.shell.linux had "usr/bin/zsh" value. But as i have uninstalled it terminal didnt open

Then i changed some values For, terminal.integrated.shell.linux, "bash" For, terminal.integrated.shell.osx, "bash" too And, terminal.external.linuxExec, "x-terminal-emulator"

It works now. I am able to use bash shell in visual code studio

Thanks everyone for helping

This is visual code screenshot

5
  • 1
    Your description is really not clear. From what I understand, you installed Zsh then uninstalled it, now you are trying to use Zsh in a terminal inside Visual Studio, but it's not working. ...But that doesn't make any sense.
    – wjandrea
    Jan 5, 2017 at 23:33
  • Does this page help? Visual Studio Code - Integrated Terminal
    – wjandrea
    Jan 5, 2017 at 23:36
  • Sir, actually when I installed zsh, i started using zsh terminal and even set it as default or something. Now that i have uninstalled zsh the visual studio settings still has zsh file's path but I want to use the basic terminal, the bash in visual studio Jan 5, 2017 at 23:42
  • 1
    Set it to /bin/bash then.
    – Seth
    Jan 6, 2017 at 1:36
  • @SachinKanthariya please edit your question to clarify
    – wjandrea
    Jan 6, 2017 at 2:21

3 Answers 3

2

Seems you have a wrong path configured on you editors (or its related terminal plugins), anyway i'll advise checking/updating your default shell provider too.

To check/update you shell provider config you can use sudo update-alternatives --config sh to list and change default between installed shell interpreters (ash/dash, zsh, fish, bash...).

Also you can directly set it to bash using sudo update-alternatives --install /bin/sh sh /bin/bash 100.

Then you should check on your editor's config and also the plugin(s) you are using to launch/open the terminal (atom-terminal, terminal-plus, etc.).

  • You should use /bin/bash where shell interpreter path is required.
  • Use /usr/bin/gnome-terminal or /usr/bin/x-terminal-emulator where the path of the terminal emulator app is required.

Hope it helps.

3
  • 1
    I think they just need to set the path to /bin/bash inside the application - they don't need to do anything with update-alternatives as far as we can tell from the question. I would suggest editing your answer to emphasise the key point, something like "in the screenshot, where /usr/bin/zsh appears, you should replace it with /bin/bash". That's my interpretation, and I would rather upvote your answer than post another one since you seem more or less on track
    – Zanna
    Jan 6, 2017 at 8:11
  • I think you're right, answer updated.
    – dgonzalez
    Jan 6, 2017 at 17:15
  • In no way, thanks to your note I have been able to improve my answer ;)
    – dgonzalez
    Jan 6, 2017 at 17:52
0

I faced this same problem recently. The easiest solution I can suggest you is to add this line in the settings.json file of Visual Studio Code. The recent version of Code lets you edit the settings.json via a GUI. Switch it to the JSON view mode. You can find that toggle button at the top right corner.

"terminal.integrated.shell.linux": "bash"

And, you're done. Run the terminal. Bash should boost up.

0
  • Open Preferences > Settings or simply use Ctrl+,
  • Search for Terminal › Integrated › Shell: Linux
  • Click on Edit in settings.json
  • Finally add this line "terminal.integrated.shell.linux" : "/bin/bash" and restart your application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.