0

I'm running 14.04LTS. Apt-get started throwing errors about unmet dependencies. I did quite a bit of troubleshooting and all of the common solutions such as sudo apt-get install -f and sudo dpkg -a --config are not working.

As usual I run sudo apt-get update which appears to work.

I cannot install the dependencies or install aptitude because any usage of apt-get returns the following errors:

$ sudo apt-get install aptitude
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptitude : Depends: libboost-iostreams1.46.1 (>= 1.46.1-1) but it is not going to be installed
            Depends: libcwidget3 but it is not going to be installed
            Recommends: libparse-debianchangelog-perl but it is not going to be installed
 libgl1-mesa-glx-lts-trusty : Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.2~precise2) but it is not going to be installed
                              Recommends: libgl1-mesa-dri-lts-trusty (>= 7.2) but it is not going to be installed
 xserver-xorg-video-vmware-lts-trusty : Depends: libxatracker2-lts-trusty but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then the fix doesn't work:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  xserver-xorg-video-fbdev-lts-trusty libwayland-ltst-client0 xserver-xorg-video-neomagic-lts-trusty xserver-xorg-video-openchrome-lts-trusty xserver-xorg-video-sis-lts-trusty xserver-xorg-video-savage-lts-trusty
  xserver-xorg-video-intel-lts-trusty xserver-xorg-video-siliconmotion-lts-trusty xserver-xorg-video-vmware-lts-trusty libmtdev1 xserver-xorg-video-modesetting-lts-trusty xserver-xorg-video-r128-lts-trusty
  xserver-xorg-video-nouveau-lts-trusty libglamor-ltst0 libxrandr-ltst2 libwayland-ltst-server0 xserver-xorg-video-cirrus-lts-trusty xserver-xorg-video-mach64-lts-trusty xserver-xorg-video-s3-lts-trusty
  xserver-xorg-video-vesa-lts-trusty libxcb-xfixes0 xserver-xorg-video-tdfx-lts-trusty xserver-xorg-video-sisusb-lts-trusty xserver-xorg-video-radeon-lts-trusty xserver-xorg-video-trident-lts-trusty xserver-xorg-video-mga-lts-trusty
  libxatracker2-lts-trusty
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libgl1-mesa-dri-lts-trusty libglapi-mesa-lts-trusty libxatracker2-lts-trusty
Suggested packages:
  libglide3
The following NEW packages will be installed:
  libgl1-mesa-dri-lts-trusty libglapi-mesa-lts-trusty libxatracker2-lts-trusty
0 upgraded, 3 newly installed, 0 to remove and 28 not upgraded.
Need to get 0 B/5,192 kB of archives.
After this operation, 34.3 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 945234 files and directories currently installed.)
Unpacking libgl1-mesa-dri-lts-trusty (from .../libgl1-mesa-dri-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb) ...
xz: /usr/lib/x86_64-linux-gnu/liblzma.so.5: version `XZ_5.2' not found (required by xz)
dpkg-deb (subprocess): subprocess data returned error exit status 1
dpkg-deb: error: subprocess <decompress> returned error exit status 2
No apport report written because the error message indicates an issue on the local system
                                                                                         dpkg: error processing /var/cache/apt/archives/libgl1-mesa-dri-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Unpacking libglapi-mesa-lts-trusty (from .../libglapi-mesa-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb) ...
xz: /usr/lib/x86_64-linux-gnu/liblzma.so.5: version `XZ_5.2' not found (required by xz)
dpkg-deb (subprocess): subprocess data returned error exit status 1
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libglapi-mesa-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
No apport report written because the error message indicates an issue on the local system
                                                                                         Unpacking libxatracker2-lts-trusty (from .../libxatracker2-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb) ...
xz: /usr/lib/x86_64-linux-gnu/liblzma.so.5: version `XZ_5.2' not found (required by xz)
dpkg-deb (subprocess): subprocess data returned error exit status 1
dpkg-deb: error: subprocess <decompress> returned error exit status 2
No apport report written because the error message indicates an issue on the local system
                                                                                         dpkg: error processing /var/cache/apt/archives/libxatracker2-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-mesa-dri-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb
 /var/cache/apt/archives/libglapi-mesa-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb
 /var/cache/apt/archives/libxatracker2-lts-trusty_10.1.3-0ubuntu0.2~precise2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo dpkg -a --configure
$

I see there is an error:

xz: /usr/lib/x86_64-linux-gnu/liblzma.so.5: version `XZ_5.2' not found (required by xz)

but when I search for it:

$ sudo find / -name liblzma.so.5
/usr/lib/x86_64-linux-gnu/liblzma.so.5
/home/dacotah/anaconda2/lib/liblzma.so.5
/home/dacotah/anaconda2/pkgs/xz-5.2.2-0/lib/liblzma.so.5
/home/dacotah/.conda/envs/outrigger-env/lib/liblzma.so.5

Any advice?

  • $10 says you set one of the LD_* environment variables. – fkraiem Jan 6 '17 at 3:07
  • Any advice on that? – user974887 Jan 6 '17 at 15:42
  • Just don't do it. – fkraiem Jan 6 '17 at 18:03
0

Try installing the packages manually.

  1. Open up https://packages.ubuntu.com/ in your web browser.
  2. Scroll down to the Search package directories area.
  3. Select your version of Ubuntu from the Distribution drop down (In this case it's trusty).
  4. Type in the package name and click search (In this case it's libcwidget3)
  5. Click on the Exact Hit (In this case it's Package libcwidget3)
  6. Select your computers architecture in the table at the bottom of your page. (amd64 for 64 bit computers, i386 is for 32 bit computers
  7. Select one of the links on the page. It's probably a good idea to select the one for your country but it doesn't matter.
  8. Open up a terminal and navigate to the directory that you downloaded the package to.
  9. Run sudo dpkg -i file.deb, where file.deb is the file that you just downloaded.

Repeat the following steps for libglapi-mesa-lts-trusty, but instead of selecting trusty in the drop down, select trusty-updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.