0

After booting today, impossible to download my mail. I get hundred of popup windows with: "unable to store downloaded mails. failed to append item"

There is no uid or permission problem in my /home. Starting kmail (kmail2 5.4.0) from the shell gives me many repeats of the first blocks below:

org.kde.pim.pop3resource: ============== ERROR DURING POP3 SYNC ==========================
org.kde.pim.pop3resource: "Unable to store downloaded mails.\nFailed to append item"
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
org.kde.pim.akonadiserver: DATABASE ERROR:
org.kde.pim.akonadiserver:   Error code: 1292
org.kde.pim.akonadiserver:   DB error:  "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1"
org.kde.pim.akonadiserver:   Error text: "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1 QMYSQL3: Unable to execute statement"
org.kde.pim.akonadiserver:   Query: "INSERT INTO PimItemTable (rev, remoteRevision, gid, collectionId, mimeTypeId, datetime, atime, dirty, size) VALUES (:0, :1, :2, :3, :4, :5, :6, :7, :8)"
org.kde.pim.akonadiserver: Error during insertion into table "PimItemTable" "Incorrect datetime value: '0000-00-00 00:00:00' for column 'datetime' at row 1 QMYSQL3: Unable to execute statement"
org.kde.pim.pop3resource: ============== ERROR DURING POP3 SYNC ==========================
org.kde.pim.pop3resource: "Unable to store downloaded mails.\nFailed to append item"
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
org.kde.pim.pop3resource: UID list from server is not valid.
org.kde.pim.pop3resource: UID list from server is not valid.
org.kde.pim.pop3resource: UID list from server is not valid.
org.kde.pim.pop3resource: UID list from server is not valid.
org.kde.pim.akonadicore: Got a stale notification for an item which was already removed. 71893 ""
org.kde.pim.akonadicore: Got a stale notification for an item which was already removed. 71893 ""

I've done akonadictl restart, and also fsck and vacuum (many messages while doing that): no change.

0

I found a workaround to the problem here: https://www.mail-archive.com/kde-bugs-dist@kde.org/msg102147.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.