I am using two different keyboard layouts, English US and Hungarian. I use them interchangeably, sometimes I type in Hungarian, my native, but often I use the US layout, especially for the terminal. I usually change layout using SUPER+SPACE. I have found out that there is a way to make Ubuntu remember that individual keyboard layout settings for different windows, but this does not apply for applications.

What I would like is that even if my currently selected layout is Hungarian, whenever I fire up a terminal, it should be immediately changed to US for the terminal window, so I don't have to bother around with that.

  • I am pretty sure we've answered this somewhere, I'll try to find it... – Jacob Vlijm Jan 5 '17 at 18:15
  • 2
    Please look here: askubuntu.com/questions/637148/… Is that what you are looking for? The question was on 12.04, the answers however were not.. – Jacob Vlijm Jan 5 '17 at 18:18
  • I should have been able to find this... This is exactly what I've been looking for, I will try it out right now. Thanks. – bp99 Jan 5 '17 at 18:21
  • 1
    @bertalanp99 The file crashed because you tried to run a bash shell script with python. It's like telling cat to bark :D Proper way to run it would be bash script.sh. For 16.04 at least, there are options in Ubuntu settings there's a way to tell Ubuntu to remember different languages per window (see this: imgur.com/a/DbMxv) , so really you don't need a script. But if you really do want a script, feel free to look at this alternative: askubuntu.com/a/656671/295286 – Sergiy Kolodyazhnyy Jan 7 '17 at 12:56
  • 2
    Possible duplicate of How to disable input language switching in terminal – Jacob Vlijm Jan 9 '17 at 7:31

Try xxkb.

From the manpage:

The xxkb program shows the current keyboard layout (an XKB group) and allows to switch it with a mouse click. It has some additional features. The xxkb remembers the layout for each application window and changes the keyboard state accordingly when the window gets a focus.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.