6

I have a problem with Redshift. It doesn't get the location from my geolocation provider 'geoclue'. The problem was more noticeable when I tried to use Maps app which said I should enable location services in order to be located. I just can't find any settings regarding this. Anyone? Thanks

P.S. Clicking on button "Location Settings" does nothing

  • What desktop environment is this? – xangua Jan 5 '17 at 20:26
  • I use Ubuntu with Unity shell (GNOME in background) – Hochopepa Jan 6 '17 at 13:06
4

From the terminal try:

redshift -l list

You should see: geoclue2

Try changing location provider to geoclue2

If you have redshift config file under ~/.config/redshift.conf this can be changed there.

4

I use Ubuntu Gnome 16.04 but should work the same:
Settings > Privacy > Location services > on
works for me, although the location accuracy is not perfect!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.