1

When I first connect the headset it works fine, but if I stop playback for some minutes and try to use it later again it gives cracking sounds and only works with breaks. I need to switch it off and on again and try different modes in sound settings before it works in a2dp mode again. sometimes it requires to switch it on and off multiple times Problem occurs on ubuntu 16.04 but I think it was on 14.04 as well. On windows, mac os, ios and android same headset makes no problems

  • 1
    Same here. Even doesn't need a break, also most times when starting next song. Fastest solution is go to Sound settings, switch to Built-in-Audio, wait 3 seconds, switch back. Very annoying! – pLumo Jan 5 '17 at 20:16
  • Most likely you need to turn on btcoex. hen you download something using Wi-Fi, BT stops without it. – Pilot6 Jan 20 '17 at 9:49
2

This happens to me too and is very annoying.

Fastest manual solution is go to Sound settings, switch to Built-in-Audio, wait 3 seconds, switch back.

I wrote a small script that is doing exactly this for me. I put it as a keyboard shortcut, so it's quicker.

#!/bin/bash
internal="1";
bluez=$(pactl list sinks short | grep -Po "^[0-9]+(?=.*?bluez)");

if [ ! -z "$bluez" ]; then
  while IFS= read -r input; do
     pacmd move-sink-input $input $internal;
  done < <(pactl list sink-inputs | grep -Po "(?<=Sink Input #)[0-9]+")
  sleep 3;
  while IFS= read -r input; do
     pacmd move-sink-input $input $bluez;
  done < <(pactl list sink-inputs | grep -Po "(?<=Sink Input #)[0-9]+")
fi

You might need to change internal to something else, you can find out with running pactl list sinks short.

That helps a bit, but is no permanent solution !

  • You can ask a new question and add there tedails of your wireless and BT adapter. – Pilot6 Jan 20 '17 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.