I've tried everything I can find anywhere.

From lsusb:

Bus 002 Device 021: ID 18d1:4ee6 Google Inc. 

From dmsg:

[ 3609.392038] usb 2-1: new SuperSpeed USB device number 21 using xhci_hcd
[ 3609.411721] usb 2-1: New USB device found, idVendor=18d1, idProduct=4ee6
[ 3609.411729] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3609.411734] usb 2-1: Product: Pixel
[ 3609.411738] usb 2-1: Manufacturer: Google
[ 3609.411742] usb 2-1: SerialNumber: FAXXXXXXXXXX

Result of adb devices:

List of devices attached 

with a blank line following

I've tried everything from this question/answer, and none of it worked.

What's odd is that it gets picked up and works from android studio, but not through terminal.

  • @LehiC I've tried MTP and PTP, and pretty much all usb modes
    – Cruncher
    Jan 5 '17 at 14:13
  • I had a similar issue. Plus eclipse ADT was not recognizing it as well. Followed this: turlucode.com/linux-android-adb-fix-permissions and got this working. MTP/PTP was not related in my case: my phone was even in USB charging mode. Only Debugging mode was on ofc. This was tested also with Android O. Hope it will help you as well!
    – Tanasis
    Aug 2 '17 at 20:55

I was also getting errors trying to connect my Pixel device:

AA69M0123456 no permissions (verify udev rules); see [http://developer.android.com/tools/device.html]

Even after setting up udev rules, unplugging/replugging, adb kill-server/startserver, re-enable developer options on the phone, etc... it still wouldn't connect.

It was because the phone USB mode was set to Charge this device. Switching it to Transfer files (via the notification menu) finally made it work.

  • Found it: Developer Options, Select USB Configuration. I set it to MTP (Media Transfer Protocol) Mode, and now the phone shows up. It was also in Charging mode for me
    – Csaba Toth
    Dec 31 '18 at 0:27
  • Also, "USB debugging" - for me, I enabled it and it started showing up on the terminal Nov 5 '21 at 21:11

I'll re-word and be more specific, as I believe my previous answer to this may have been misconstrued.

I'm under the assumption that you are attempting to access the phone's internal storage and/or the SD card inserted.

That being the case, if the phone is running Android OS (it's Google, it should be), then you should receive a notification as to the mode the phone is in, with regard to the USB connection.

Typically, simply pulling down the notifications section would allow you to "tap and toggle". Other than that, you can go into the settings section of the phone to see if there is an option to toggle it to something resembling the wording "Share Files".

Aside from that, you may need to dive into the documentation that should have been provided with the phone.

Since it seems to support Mac (which is also UNIX based) it, hypothetically, should be usable with Linux. Aside from that, you may need to contact Google directly for more explicit instructions for getting the phone to interact with Ubuntu.


  • 6
    adb is not typically used "to access the phone's internal storage and/or the SD card inserted". Rather, it "is a versatile command line tool that lets you communicate with an emulator instance or connected Android device. " Jan 5 '17 at 2:05
  • 1
    Since OP mentions Android Studio I don't think that access to the internal storage is going to be enough. During software development one needs to execute additional commands on the phone. Jan 5 '17 at 10:26
  • 1
    @DavidFoerster this is correct. There are several "how-tos" that I've read that all start with "make sure your device is visible via adb devices"
    – Cruncher
    Jan 5 '17 at 15:45
  • You have the full capacity to edit your questions here, instead of reposting you can just edit an answer to make it more informative, etc. next time
    – Thomas Ward
    Jan 6 '17 at 0:24

When faced with the same issue as the OP I came across this post. I wanted to come back and contribute what worked for me.

I discovered the version of ADB that ships with Ubuntu is 1.0.31 which only works up to Android 5. You need the newest adb version 1.0.32 which supports Android v7.1 which is what ships with the Pixel. That question was answered here: How to Update or Re-Install the newest version of ADB?

I also discovered that there's a bug with USB 3 on some machines, plugging in a cheap USB 2 hub (or an old adaptor) was the final ticket to getting adb devices to detect my Pixel. (It sounded weird to me too, but it worked).

I'm not sure if adding a udev rule helped or not, but I did also did try that earlier in the process. Maybe if someone else comes along they'll be able to clarify that step.


Switching from USB to USB-C worked for me on a pixel 5 using adb and droidcam.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.