2

I have been using the driver for my network scanner (DCP-7070DW) with success for quite a long time and I am still using it on other running computer. But I am having a hard time installing it on my fresh Ubuntu 16.10 install even if it still works after upgrading the other ones.

Running scanimage -L fails with a segfault.

$ ldd /usr/bin/scanimage 
linux-vdso.so.1 =>  (0x00007fffcefad000)
libsane.so.1 => /usr/lib/x86_64-linux-gnu/libsane.so.1 (0x00007fd82ed31000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd82e96a000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd82e766000)
/lib64/ld-linux-x86-64.so.2 (0x00005651dc8dc000)

If I run GDB

(gdb) run -L
Starting program: /usr/bin/scanimage -L
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff73ecd3e in __pthread_initialize_minimal_internal ()
    at nptl-init.c:322
322 nptl-init.c: Aucun fichier ou dossier de ce type.

My /etc/sane.d/dll.conf has got brother4 as the last line as expected.

I have got:

  • /usr/lib64/sane/libsane-brother4.so
  • /usr/lib/x86_64-linux-gnu/sane/libsane-brother4.so

Any idea of how to fix the matter?

1

I did a ldd /usr/lib64/sane/libsane-brother4.so and I've got:

libusb-0.1.so.4 => not found

So I guessed I would need to install this dependency.

To install it, just run: sudo apt-get install libusb-0.1-4

And voilà:

$ scanimage -L
device `brother4:net1;dev0' is a Brother DCP7070DW DCP-7070DW
1
  • I had to do it again today :D – Natim Mar 6 '17 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.