1

Steam will not start on my new Kubuntu 16.10 system. Here is the output of running it from the terminal:

Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME is enabled automatically
/bin/bash: /home/[username]/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
Installing breakpad exception handler for appid(steam)/version(1482202200)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Then it just hangs and doesn't start. I Googled the error and tried these methods but none of them worked for me. I have had Steam work in the past, but some new NVIDIA drivers were causing a black screen so I re-installed them with sudo apt-get install nvidia-current, and according to the Driver Manager the legacy drivers are selected (version 304.132 according to Driver Manager, I can't verify fully as nvidia-smi isn't installed). This issue also happens with the open source Nouveau drivers.

The system has a GT 650M Mac Edition GPU with a Core i5-3470S as the CPU.

  • The problem is most likely caused by old drivers. Unfortunately, you felt into the nvidia-current trap (you assumed it installs the latest version and you're not alone, the name is really misleading. The driver you have now does NOT support a GT650M. You need 352, 361, 367, 370 or 375 (recommended). Remove all traces of previous installations - sudo apt purge nvidia* and reboot before installing the proper version. – user589808 Jan 4 '17 at 16:54
  • I've set the driver to a newer one in the driver manager, I'll see if I get the black screen after a reboot. That works as well right? – Matt Young Jan 4 '17 at 16:58
  • Have you missed the part about removing all traces of the previous installations? You've been warned. – user589808 Jan 4 '17 at 17:01
  • No, I haven't missed it. The reboot was successful, however, the Steam issue persists, so I'll follow your advice and purge the old NVIDIA drivers. Where can I get the newest ones? – Matt Young Jan 4 '17 at 17:03
  • In "additional drivers" as usual. IDK which is the latest version available in the 16.10 repos but one of the aforementioned versions should be there. You can add the Graphics Drivers PPA to obtain newer versions like 375. – user589808 Jan 4 '17 at 17:05
0

Running this command appears to have fixed it:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

as per this answer and also this one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.