0

I got some very strange problems with my Laptop keyboard/mousepad...

I have two partitions on my SDD, one with Ubuntu 16.04 and the other one with Windows 10 (using GRUB as bootloader). Yesterday evening I put Ubuntu to suspend mode. Today I continue working on it - but it comes back with a strange behavior...

The mouse is jumping from the left bottom screen to the right top screen and executes randomly clicks.. The mousepad and keyboard does not reacting on input. I have to connect an external mouse and keyboard to perform input. But the mouse is still (annoying) jumping and clicking around. Then I try to see what xinput is saying - xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Gaming Mouse                 id=14   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ WebCam SC-13HDN10939N                     id=11   [slave  keyboard (3)]
    ↳ Cherry GmbH wired keyboard                id=12   [slave  keyboard (3)]
    ↳ Cherry GmbH wired keyboard                id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]

Then I disabled the PS/2 Generic Mouse by xinput --disable 16. Finally the random mouse moves stopped... (If I restart the system at this point, the moves come back...)

Then I tried sudo apt-get install --reinstall xserver-xorg-input-all to reinstall the drivers. But with no success, keyboard and mouse still not reacting on input... Even on GRUB the keyboard does not working.

I do not know if this is important: An extern mouse was connected to the Laptop, before I put it to suspend. Logitech USB Gaming Mouse

What could be the problem?? Can anyone please help me...

EDIT: Even on BIOS the laptop keyboard does not working. Only with an extern keyboard. But in the GRUB menu both keyboards does not working, so I can not even run windows again... How should the keyboard get destroyed?!

  • 1
    wow, weird. Have you tried rebooting into Ubuntu? – Zanna Jan 4 '17 at 12:56
  • Sounds more like a hardware issue or at least a BIOS issue than a Ubuntu issue. What motherboard does your laptop have, and what BIOS version are you running? – anonymous2 Jan 4 '17 at 15:47
1

Ok I have the solution (but not the reason) of the problem! (@Zanna - yes, 10 times or something like that and with that annoying mouse problem and no solution) Resetting the Motherboard

Take of battery pack (and disconnect from current source) for min. 5 minutes, then press the power button (without the battery or current source) for 30 seconds. Then put the battery pack back, press power -> it works now perfectly like the day before .... halleluja

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.