0

I start pc, it goes through bios ok, goes through grub ok, even displays xubuntu splash image (big xubuntu on blue-white background) and stops. I can get in tty1, even log in, but no desktop. Tried startxfce4 only to see fatal server error server already running. How do i get my desktop back, as it was before this problem, without reinstalling my system preferably. Also, im not-native english, linux beginner.

edit: it is dell optiplex gx280, no wifi, no bluetooth, graphics card is eah5450 silent/di/1gd3(lp) with the graphics engine AMD Radeon HD 5450.

Yesterday i turned it off like every day, and today its stuck on black screen.


Not fixed, reinstalled.

  • Please add a description of your computer (brand name, model, graphic chip/card, wifi chip/card). Can you remember what happened before this problem started (did you install something, was it an automatic update)? It makes it easier for us to help. – sudodus Jan 4 '17 at 10:24
  • i will check back in few hours – Nomo Hakon Jan 4 '17 at 11:21
  • There might be a problem with the driver for the graphics card. Are you using the free driver? There might also be a hardware problem. Please try live with an install USB drive or DVD disk 'Try Xubuntu'. It should work with 16.04.1 LTS or 14.04.1 LTS or 14.04.5 LTS if the hardware is OK. – sudodus Jan 4 '17 at 12:18
  • live usb xubuntu 16.04 or .10 worked fine, im using manufacturers driver with updates. its definitely software thing, just no clue what. i dualboot with win xp sp3 and they work rock-stable. – Nomo Hakon Jan 4 '17 at 12:38
0

I'm glad that the hardware is OK :-)

The problem might be that the proprietary drivers for Radeon chips are no longer developed/supported. On the other hand, the corresponding free driver is developed and quite good in 16.04.1 LTS and newer versions of Ubuntu.

Please try to switch to the free driver (by removing the proprietary driver). If we are lucky it will work with your graphics card.

This link shows how to remove the proprietary driver for Radeon cards:

askubuntu.com/questions/68306/how-do-i-remove-the-proprietary-ati-drivers

Otherwise you can use an older version, where the proprietary driver is still working, for example 14.04.1 LTS. Unfortunately that version of Xubuntu is only supported for 3 years, until April this year. But in the meantime you might find another solution.

  • But if the splash image works, how can it be the driver? Or is it some weird linux bug/feature? Also how do i remove the proprietary driver using cli? – Nomo Hakon Jan 4 '17 at 13:05
  • I added a link that shows how to do it. – sudodus Jan 4 '17 at 13:10
  • Did not help, its the same as before, so it wasnt the driver, but somewhere higher. – Nomo Hakon Jan 4 '17 at 13:24
  • Have you tried with some boot options, for example nomodeset? See this link about boot options, ubuntuforums.org/… – sudodus Jan 4 '17 at 13:28
  • altering boot options did nothing. – Nomo Hakon Jan 4 '17 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.