EDIT: don't do what I did in this question, check out the answer section below!

Screen shows up with this after running Ubuntu from grub64efi:

gave up waiting for root device. Common problems:
        boot args (cat /proc/cmdline)
        Check rootdelay= (did the system wait for long enough?)
        Check root= (did the system wait for the right device?)
    Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=1234-etc... does not exist. Dropping to a shell!

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) _

I made dualboot of Windows 10 and Ubuntu 16.04.

How I got this far:

  1. First installed Windows, updated it, drivers and bios.
  2. made Ubuntu live-USB with Rufus (Uefi option or both).
  3. I manually changed from bios(F2 on DELL-logo screen on start):
  4. Secureboot disabled,
  5. Enabled legacy options ROMS,
  6. added option to boot sequence to the USB,
  7. and changed boot sequence to UEFI, run that new boot option(F12 on DELL screen)
  8. I made 30GB free partition space in SSD with GParted on live-USB-ubuntu.
  9. and Installed Ubuntu 16.04 on it. (Option with something like: "on side with windows")
  10. restarted, pressed F2 to go to bios and added Boot option of new partition and looked up (FS0:)/EFI/ubuntu/grubx64.efi
  11. After that it loads grub and when I select Ubuntu and it gives me that initramfs-shell.

ls root gives nothing, same as with ls boot.

I'm pretty new to Linux, so I'm glad at least 1 OS works on it, though it would be great if I could get Linux working on it too..

EDIT:

I run that Boot-Info-program in live-usb.

it gave me this on uefi mode: http://paste2.org/6aO3Lf5B

and this on legacy mode: http://paste2.org/P5U5ms9V

  • May be best to see details, you can run from Ubuntu live installer or any working install: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info Similar model with lots of links to threads on Dells.ubuntuforums.org/showthread.php?t=2348050 – oldfred Jan 3 '17 at 14:49
  • @oldfred I added the pastebins on the main post. I hope they help. – J-ho Jan 4 '17 at 16:50
  • UEFI mode is not showing NVMe drive at all. But probably due to Windows fast start up. askubuntu.com/questions/843153/… But may be due to UEFI/BIOS in RAID mode? Since Windows is UEFI, you need to install Ubuntu in UEFI boot mode. You may want to partition in advance with gparted, which must be at least v24 to support NVMe drives. – oldfred Jan 4 '17 at 17:46
  • @oldfred yes there is in bios SATA OPERATION which has 3 options: Disabled, AHCI and RAID On. Raid On is checked. Should I try changing it to AHCI and try to install ubuntu in UEFI mode? it gives me a warning about changing it. I did make a recovery usb for windows though so I might be fine.. – J-ho Jan 4 '17 at 19:11
  • @oldfred Well I did that. Changed to Uefi mode, changed SATA operation to AHCI and installed Ubuntu from live-USB. now When my drive is in AHCI I can run grub&Ubuntu fine, but not Windows. Then when I go change it back to RAID I can run Windows but not grub&Ubuntu. – J-ho Jan 4 '17 at 20:08
up vote 18 down vote accepted

DUALBOOT Windows & Ubuntu on Dell XPS 13 9360

Big thanks to @oldfred for help!

Short answer: Dell XPS 13 2016 (intel i5 9360, KabyLake) has SATA operation in RAID mode, which doesnt' work for Ubuntu. You need to change it to AHCI. Also disable secureboot so you can see usb and install it. You may need to add usb in boot sequence as option. In windows you need to disable fastboot so Ubuntu can recognize partitions correctly.

This is for future reference for me and all of you Dell XPS 13 9360 owners. I'm Using BIOS version 1.2.3. Ubuntu 16.04. Windows 10. Dell XPS 13 9360 manufacture date: 11/2016. It may or may not work on your setup.

Long answer/steps to take you through it:

Setting up windows and bios:

  1. If you have installed Windows already and maybe you should. Do a recovery USB-stick.(minimum 16Gb USB-stick, I used 32GB stick).
  2. Update BIOS, if link doesn't work google: "Dell XPS 13 9360 drivers"

Setting up live-ubuntu USB

  1. Download Rufus and Ubuntu.
  2. use Rufus to add Ubuntu in the USB (min 6-8GB?) (another USB than the one with recovery): choose UEFI option.

Installing Windows in AHCI mode

  1. restart, open bios(F2) when DELL logo comes up.
  2. Change secure boot disbled: BIOS->Settings->Secure Boot->Disabled.
  3. Change Sata Operation to AHCI: BIOS->Settinsg->System Configuration->SATA Operation->AHCI.
  4. Click "Apply"-button at bottom right in bios.
  5. If Windows loads you're golden, if not select: more options, and somewhere in there is "restore with default settings" or something in those lines.

You may try to install Windows with your recovery USB too. (you may need to add the usb to boot sequence in BIOS)

Now if your Windows starts up you need to do one more thing so Ubuntu can recognize partitions correctly.

  1. Disable fastboot in Windows: Power Options->Choose what the power buttons do->Change settings that are currently unavailable->uncheck "Turn on fast startup"

Installing Ubuntu

  1. You may need to add USB to boot-sequence if it doesn't load when you restart with ubuntu-USB on laptop: go to BIOS(F2 on dell logo)->Settings->Boot Sequence->"Add Boot Option"-button, add name and choose option with usb in File System List, not the one with "Pci"-in the name.. click "OK".
  2. Select in Boot Sequence your usb and move it all the way up with the arrow buttons, so it boots first.
  3. Then in BIOS click "Apply" and "Exit". This will restart your laptop.
  4. Now you should boot up in grub like environment, select "try ubuntu".
  5. Open Gparted, resize biggest partition so we can fit Ubuntu. Make atleast 20GB for Ubuntu. I did 50GB.
  6. Run the Ubuntu Installer. Do your configurations, select all update options. Choose the option with "along side Windows".

Now you should have Windows and Ubuntu on your laptop!

  1. You can go to BIOS settings and set the option "Ubuntu" in boot sequence first so you start up in grub.

If this helped you, please give me 1+up, so others can find this answer easier.

UPDATE:

I've updated to BIOS 1.3.7 few days ago. Seems to work fine. If you have problems with tracpad palm recognition in Ubuntu, update your Ubuntu or try this: https://medium.com/@patrickmmartin/dell-xps-13-9360-journey-to-linux-trackpad-fix-a2d9b551d291 If you still are in Safe mode in Windows try this:http://www.pcworld.com/article/3085034/windows/how-to-get-out-of-windows-safe-mode.html

UPDATE 2:

I've updated to BIOS 2.3.1 and everything seems to work fine. Though same problems exists that I've found before:

  • touch-pad gets uncontrollable after a long time of use in Ubuntu.
  • Windows shuts down itself unexpectedly sometimes for unknown reason, going blue-screen.
  • Windows shutting itself down after no use, gets error shutting down.
  • usb 2.0 devices don't work correctly, like external-SSD and such. Though I got Logitech's Unifying USB receiver working after installing their software. Unifying receiver works fine in Ubuntu.

I think errors in Windows might be due to incompatibility with grub-launcher or dual-boot itself. As of now if you want trustworthy experience in Windows side I don't recommend dual-boot.

EDIT:

Dell released a guide to make a dualboot for windows and linux on dec. 2017, that might be very helpful: http://www.dell.com/support/article/nz/en/nzdhs1/sln301754/how-to-install-ubuntu-and-windows-8-or-10-as-a-dual-boot-on-your-dell-pc

  • 2
    Glad you figured it out. While using gparted with NTFS usually works, often better to just use Windows to shrink the NTFS partition and reboot immediately as Windows also wants to run chkdsk after any resize. – oldfred Jan 5 '17 at 17:52
  • 1
    look into disabling bitlocker on windows before disabling secureboot in bios. Will update once I get un-locked out. – spazm Mar 6 '17 at 0:07
  • I've updated to BIOS 1.3.7 few days ago. Seems to work fine. Also I had little bit of problems with trackpad palm recognizion in Ubuntu. But it seems to be either fixed or I'm lucky. Either way update your Ubuntu and it should be fixed, if not you might wanna try this Also if your Windows is on safe mode try this – J-ho Jul 27 '17 at 10:34
  • Dell's guide didn't mention a thing about SATA operation AHCI mode. They should refer to your answer here really! – Gan Apr 4 at 17:58
  • Using "Rufus" made a difference. I was trying with "Startup Disk Creator" in Ubuntu, but with that, the created disk was not being visible in BIOS. Thanks! – Arun Saha Apr 19 at 15:20

Dell xps 13 9360, BIOS - 2.3.1, Manufacture - 7/Feb/18, 500Gb SSD

In Australia, Dell does not offer pre-loaded Linux. They also completely disown you if you try to do it yourself. That makes it a bit daunting.

The following worked as at Feb.2018.

I've read there are some problems with the later UEFI(BIOS) version so I didn't upgrade.

http://www.rationaljava.com/2016/10/dell-xps13-dual-boot-windows-10-with.html had useful information.

  • shrink Windows partition to make space for Linux

    (https://www.easeus.com/partition-master/resize-partition-windows-10.html)
    While booted into Windows 10:Using "Computer Management->Disk Management" tool
    I had to shrink it by max 100G at a time for some reason
    Maximise Ubuntu installation > 300Gb in my case
    
  • turn off bitlocker encryption:

    Control panel->update&security
    Not sure if it's necessary to turn off bitlocker???
    
  • turn off fast boot: (Unable to mount Windows 10 partition; it "is in an unsafe state")

    Right click on start, OR windowskey/+x
    Choose: Power Options
    "additional power settings" (on the right)
    "choose what the power buttons do"
    "change settings that are currently unavailable"
    Uncheck fast startup
    (I also changed "When I press the power button" to "shutdown")
    
  • enter "safe mode":

    For some reason, you need safe mode to set disk to AHCI
    At Windows start/search, type "msconfig" then <enter>
    Select boot tab
    Click safe mode, minimal
    Reboot - requires full password from your initial setup.
    
  • set AHCI:

    Make sure you have put Windows into safe mode before doing this
    Restart Windows
    Press F2 during reboot
    system config -> SATA -> AHCI -> yes
    reboot
    Exit safe mode (reverse enter "safe mode" - see above)
    Reboot and hope like hell that windows works - it did!
    
  • disable secure boot option

    Boot into UEFI/BIOS (press F2 during boot) and disable secure boot
    You can do this at the same time as setting AHCI.
    
  • Add boot option

    Plug in bootable USB with linux FIRST, then
    Reboot into UEFI (F2 at boot)
    From "General -> Boot Sequence", click "Add Boot Option"
    Give this boot option a name, eg: "linux"
    From the file system list, select the one that includes "USB" in it's path
    For "File Name", use the widget to select /EFI/BOOT/grubx64.efi
    Click OK, note there is now a Boot sequence option for "linux"
    Using the arrows on the right, move "linux" to the top of the boot sequence
    Apply and Exit. I did not save as custom setting.
    Make sure you leave the bootable USB inserted when rebooting.
    
  • Install Ubuntu - don't forget to remove USB after it asks for reboot.
  • Reset display: settings->Displays->Resolution-> 1920x1080 / 16x9 aspect
  • After installation, a grub menu including Windows will appear when rebooting.
  • Give thanks to the digital gods that it all went well.
  • It is not necessary to turn-off BitLocker. – Paulo Ney May 13 at 5:11

Just installed Ubuntu on an XPS 13 9360 Kaby Lake i7-7560U.

The above procedure worked except for getting Windows to boot in ACHI (step 9 in J-ho @ Jan 5 at 10:55). Here I used this trick to boot into Windows Safe Mode, then switch BIOS to ACHI: http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

I downsized the Windows partition in Windows itself, which was painless and quick. I did not need to update the BIOS. I used a standard Ubuntu 16.04 64-bit USB stick.

  • After moving to latest BIOS(1.3.2) I had to disable Secure Boot again to keep updating my Ubuntu. You can do it in BIOS. AHCI wasn't changed, but It can be found in BIOS too. – J-ho Apr 3 '17 at 6:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.