0

I am trying to install phpMyAdmin on Ubuntu 16.04 LTS.

Steps followed:

  1. Successfully installed Apache2

  2. Every time I try to install phpMyAdmin, I am getting this error:

    mysql: [Warning] mysql: Empty value for 'port' specified. Will throw an  
    error in future versions ERROR 1045 (28000): Access denied for user         
    '*<username>*'@'localhost' (using password: YES) . Your options are:                  
    * abort - Causes the operation to fail; you will need to downgrade,        
    reinstall, reconfigure this package, or otherwise manually intervene     
    to continue using it. This will usually also impact your ability to      
    install other packages until the installation failure is resolved.       
    * retry - Prompts once more with all the configuration questions           
      (including ones you may have missed due to the debconf priority          
      setting) and makes another attempt at performing the operation.          
    * retry (skip questions) - Immediately attempts the operation again,       
      skipping all questions. This is normally useful only if you have  
    
  3. I tried using a Ubuntu login ID with sudo privileges in place of . No luck

  4. Tried providing another username . Same error

  5. Tried retry several times with questions. Same error.

What should I do to fix this? Also I would like to use localhost as the server (db,web) Thanks.

  • 1. You need to install MySQL. In this process you will set a password for the root user of MySQL. If you have done that but you don't remember the password you can change it manually: dev.mysql.com/doc/refman/5.7/en/resetting-permissions.html 2. In the process of phpMyAdmin installation you need to use this password. – pa4080 Jan 3 '17 at 15:17
  • To check that MySQL root's password is working you can log in with this command: mysql -u'root' -p. – pa4080 Jan 3 '17 at 15:36
  • @SpasSpasov MySQL is installed. I still get this error. – moonstar Jan 3 '17 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.