3

My machine is a Dell Mini Inspiron 1018 running on Intel GMA 3150 (old integrated graphics) and it crashes/freezes when booting up. I did a fresh install of Lubuntu 16.10 32-bit; it installed without any issue and booted up once.

But after restarting the second time, I got stuck at the following lines when using the "quiet" kernel parameter:

/dev/sda1: clean, 124636/9707520 files, 1564513/38812928 blocks

and without it, the last line before freezing is never the same; most of the time, the line is:

Starting Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight...

and sometimes it is:

Reached target Sound Card.

or

Starting Load/Save RF Kill Switch Status...

Thinking the issue was the backlight, I've tried inserting the following kernel parameters: acpi_backlight=vendor and/or video.use_native_backlight=1 and yet, same results. But I might be wrong and Lubuntu might not properly support my old GPU.

I can't boot up in recevory mode neither or by adding the nomodeset kernel parameter; it crashes at the same lines, so I have no idea how I could install new drivers if I have to.

What are my options at this point? What kernel parameters should I try, should I install the Intel GMA 3150 drivers if I need to, should I reinstall Lubuntu 16.10 or another Ubuntu variant or should I wait for the issue to get fixed in a future update?

Sorry in advance if there are many spelling mistakes; English is not my first language. Thank you!


EDIT 02/01/2017 @ 21:54 I've managed to successfully boot up by adding this kernel parameter:

systemd.restore_state=0
  • Your hardware is 64-bit, so you should install the 64-bit version of Lubuntu. 32-bit versions of Ubuntu will be discontinued in the near future. It's possible that the 64-bit edition won't have the problem that you're experiencing, too. – Aaron Franke Jan 3 '17 at 3:14
  • @AaronFranke It has the same 'bug' on the 64-bit version of the same computer. I have used a couple of hours searching for this issue before I ended here - and the above answer fixes it :) – dennis Sep 24 '17 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.