1

I created an Ubuntu core SD for my Raspberry-3 and booted it. Then from my IPad using an app I tried to SSH to it. As far as I understood from the instructions I should not be asked any password to login. But I am being asked a password:

root@Ubuntu-1:~# ssh rpi@192.168.1.7
The authenticity of host '192.168.1.7 (192.168.1.7)' can't be established.
ECDSA key fingerprint is SHA256:yfOBN1/EPQ8v6b1+n6QFCAj/+tyruioord
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.7' (ECDSA) to the list of known hosts.
Rpi@192.168.1.7's password: 
Permission denied, please try again.    

If I can access to RPi I can set a password for local access, but I cannot, since I do not know what ethis password is. How can I resolve this puzzle and access my newly created Ubuntu running RPi?

7
  • You need to make setup on first boot, register the device with you Launchpad account and ssh key. This requires actually physical access, via keyboard or via usb to serial connector. Have you done that ? Jan 2 '17 at 23:20
  • Hello Serg, I certainly did. The installation asked my Ubuntu one login email than successfully registered. But then comes and asks login ID and password. So, I tried to SSH to it by using SSH rpi@192.168.1.7, but this one is asking a password? What password? Supposedly I do not need one. This is my problem. I cannot access RPi I just created! Jan 3 '17 at 0:04
  • 1
    rpi@192.168.1.7 < --- that's the problem. You're supposed to ssh with your launchpad name. For example, my launchpad user id is 1047481448-2 so I would use ssh 1047481448-2@192.168.1.7 Jan 3 '17 at 0:19
  • 1
    Just a side note: if you find this setup too complex, there's also community-maintained Ubuntu MATE image for raspberry. It's unofficial, but works about the same as other images for arm devices. If you won't figure out snappy core, consider using that Jan 3 '17 at 0:24
  • Hello Serg. Thank you for your help. What is launchpad? is it my Ubuntu SSO account name? This is where I saved my SSH keys and uploaded. So my SSO account name is athena (I created this in Ubuntu One, and imported the SSH key I created in an Ubuntu computer). Then in order to login to the newly created rpi Ubuntu computer I type athena@192.168.1.7 from the Ubuntu computer I created the SSH keys. But I still get password request. The password I created during the SSH creation does not work, and I get "Permission denied" error all the time. Jan 3 '17 at 20:48

Browse other questions tagged or ask your own question.