0

Typing ^<space> outputs ^, and x^2 outputs . How can I disable this setting? I'd like x^2 to output x^2.

  • In what application? Does it do this is a terminal? – AlexP Jan 2 '17 at 22:11
  • Yes, this happens in Terminal, Firefox, Texmaker, the Type-to-search box, Nautilus. – Kurzd Jan 2 '17 at 22:46
0

Your keyboard layout is most likely set to English (US, international with dead keys). Open Region and Language in System Settings and change the Input Source to English (US) or whatever matches your actual keyboard.

  • English (US) makes ^ work the way I want, but that's not a layout I'm used to. I tried all of the Spanish (Latin America) layouts, two lack the ^ character and the other two behave in this annoying manner :( – Kurzd Jan 3 '17 at 1:30
  • @Kurzd: Have you seen "How can I get the correct Spanish Keyboard layout"? – AlexP Jan 3 '17 at 1:52
  • Spanish (Latin American, eliminate dead keys) is a bit different than I am used to but the ^ key works the way I want it to. I'm going to try this layout for a few days. – Kurzd Jan 3 '17 at 2:22
  • Actually, ^ works a bit different than intended, but doesn't force that number superscripting. The ´, however, appears on-screen as soon as the key is pressed, disabling any kind of accents, which is terrible. The way it worked on Windows, for ^ and ´ was to do nothing if pressed, but output an accented letter if a letter was pressed after, and output the accent and a non-letter if a non-letter was pressed after. This is what I've been trying to accomplish. – Kurzd Jan 3 '17 at 2:55
  • @Kurzd: Maybe you should return to Spanish (Latin America) and live with pressing a space between ^ and 2... – AlexP Jan 3 '17 at 3:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.