1

I am logged in to some server with smbclient and I am sharing a LaTeX project (contained in directory) with other people. Currently, all files seem to have permissions 600. For other people to be able to collaborate, they (i.e. anyone) must be able to modify all files within that directory. However,

chmod -R 777 directory

returns NT_STATUS_INVALID_PARAMETER How do I apply chmod recursively within a smbclient prompt?

  • is directory on an NTFS filesystem? Also note that setting 666 on a directory will make it completely inaccessible to everyone (please see the permissions tag wiki) – Zanna Jan 2 '17 at 11:03
  • You should use chmod -R 777 directory which will give permissions to all files currently in the folder and files added in the future without giving permissions to the directory itself. – Arduino_Sentinel Jan 2 '17 at 11:14
  • @Arduino_Sentinel that does change the permissions of the directory itself – Zanna Jan 2 '17 at 11:43
  • 1
    Possibly you should use smb.conf, if the mount options allow read/write? I don't have experience with smb, I just commented originally because I saw an ill-advised chmod :/ I hope someone with the right expertise finds your question. I will upvote it now... – Zanna Jan 2 '17 at 13:09
  • 2
    Possible duplicate of How do I use 'chmod' on an NTFS (or FAT32) partition? – Zanna Oct 6 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.