I am trying to block system shortcuts while using certain shortcut-heavy applications. That already works fine with shortcuts that are accessible via dconf and gsettings. However, I can not find the shortcuts defined by Unity/Compiz anywhere in (d|g)conf-editor; I mean those that are shown when holding Super.

While they can be changed using the Compiz config settings manager, CCSM does not seem to provide a command-line interface.

How can I programmatically (re)set Unity's/Compiz' top-level keyboard shortcuts?

  • Whatever is in CCSM is frequently is in dconf , so doing dconf watch / and then toggling those shortcuts on / off will tell you which schemas manage them. Not everything is in dconf though, some shortcuts i think are hard-coded into Unity. – Sergiy Kolodyazhnyy Jan 2 '17 at 11:10
  • Some compiz plugins which interface wiith shortcuts can be disabled, but i personally wouldn't recommend. Can be done but just not a good idea in my experience – Sergiy Kolodyazhnyy Jan 2 '17 at 11:12
  • @Serg Thanks for the hint. I tried for ALT+F1; turns out the default state is "enabled, no entry in dconf" but when you change it, an entry is created. No wonder I couldn't find any binding in dconf-editor... Blerg, this seems to be ugly... (I can't find ALT+` in CCSM; where else can I look?) – Raphael Jan 2 '17 at 11:53
  • Oh, my... – Raphael Jan 2 '17 at 11:55
  • Yep, that's what it is. May I ask, is using Unity absolutely necessary ? Have you considered switching to another desktop environment ? – Sergiy Kolodyazhnyy Jan 2 '17 at 12:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.