4

I have an iMac 5K. In macOS, the maximum resolution was 5120 x 2880, displayed as 2560 x 1440 HiDPI.

I've installed Ubuntu 16.04 Desktop, dual-booting using rEFInd. However, rEFInd displays at 3840 x 2160 resolution, and both Ubuntu and macOS as loaded by rEFInd are limited to this resolution as well.

Clearing the iMac's NVRAM reverts back to the standard Apple boot manager which loads macOS at 5120 x 2880 again, but doesn't recognise Ubuntu as an option. Clearing just the display-options key from NVRAM keeps rEFInd booting, but doesn't increase the resolution.

I tried setting a new resolution in rEFInd's configuration, but the only available mode reported is 3840 x 2160.

This discussion indicates that rEFInd isn't necessarily to blame, so I've tried Frankenstein-ing in the CsmVideoDxe.efi driver from Clover, which supposedly increases the available range of resolutions but it had no noticeable effect.

I'm afraid to go any deeper on my own as I don't want to end up with an unbootable iMac. What can I try next?

Edit: Tried two further things. 1) Clearing NVRAM to use Apple default boot loader then running GRUB from Ubuntu Live USB still limited the resolution, so it's definitely not rEFInd. 2) Setting the spoof_osx_version property in rEFInd's configuration to either 10.9 or 10.12 also had no effect.

3

It's not your fault

This is a known bug with the iMac 5k, and occurs even when using Boot Camp to dual boot with Windows!

Here's a video mentioning the problem: https://youtu.be/tgTMxB-ffjM?t=3m44s

I don't really think there's anything you can do about it, unfortunately :(

7
  • Thank you! (can't upvote till 15 rep). A link in that video's comments indicates that in Nov 2016 new drivers were released by Apple that allowed Windows to use the full resolution. So, that's something. Not much, but something. Jan 2 '17 at 1:43
  • @tobygriffin - Interesting. I didn't read the comments; actually the only reason I was able to direct you to that video was because I had watched it a year or two ago when it was first uploaded, and when I read your question, I just happened to remember Linus mentioning a resolution problem... So I just searched his channel for iMac and there was the video :) In any case, the bottom line is Apple is using proprietary stuff, and that's causing problems. And since Apple doesn't support Linux (although OSX is based on Linux, funnily enough), I doubt there will ever be a fixed driver for Linux. Jan 2 '17 at 2:29
  • Thanks for the additional info, Android Dev. I've added a link to that YouTube video to the rEFInd todo.html documentation file. Oh, and BTW, OS X is not based on Linux; it uses the XNU kernel, which in turn is derived mainly from the Mach kernel, as I understand it.
    – Rod Smith
    Jan 2 '17 at 23:52
  • This Apple Support page, updated May 2016, explicitly says "Note that Boot Camp supports resolutions up to 3840-by-2160". So, that seems to indicate that Apple does tricky private things to get above that resolution. However, the release of high res drivers for Windows recently means that maybe there is some future hope. But nothing right now, so I'll give your answer the tick. Thanks. Jan 3 '17 at 10:30
  • @RodSmith - Huh. I always thought that OSX was based on Unix/Linux. You learn something new everyday :) Jan 3 '17 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.