3

I'm using Ubuntu 16.04.1 LTS. I have two USB audio devices on my machine.

My normal account uses the qtile window manager, so there's none of the normal GNOME/Unity stuff. PulseAudio doesn't work well there (more on that later).

I created a secondary account using adduser, and logged in -- this one, of course, uses GNOME/Unity. PulseAudio works fine on this other account.

In the case of the first account, when I say "it doesn't work correctly", I mean:

  • If I start pulseaudio by running pulseaudio -D or start-pulseaudio-x11, then run a command to play back music, then sound is played back much faster than it should be -- I estimate at 60x the correct speed. Playing the music again has the same effect.
  • If I kill pulseaudio by running pulseaudio -k then just run the music-playing command, then it works the first time. However, the next time I run the music-playing comment it plays back at high speed again. Killing the pulseaudio demon makes everything work again for one play, then things go back to high-speed playback.

Given that sound works fine in the secondary account, I assume that the problem isn't a system-side setting. It must be something different between the accounts. The different window manager is one suspicion I have -- perhaps GNOME or Unity are setting something up for me that qtile isn't?

Or perhaps it's some other hidden settings file. I've looked at all of the config files in my home directly but haven't found anything obvious.

Any suggestions? Any useful debugging stuff I could run?

[updates as per comment thread with @Takkat] I've already tried removing ~/.config/pulse, and it doesn't change anything. Additionally, I've discovered since posting this that if I log in using GNOME/Unity, sound works just fine. So I'm 99% sure there's something clever that my config isn't starting when I log in using qtile. Any suggestions would be really much appreciated!

  • 1
    It most likely is an erroneous setting in your config. For pulseaudio these settings can safely be deleted (unless you had a custom default.pa there). See askubuntu.com/questions/201780/… for more details. – Takkat Jan 2 '17 at 9:33
  • Thanks for the suggestion, but I don't think it's that. I should have said in the original question, I'd cleared out all of the ~/.config/pulse stuff and it didn't help. – Giles Thomas Jan 2 '17 at 23:40
  • Additionally, I just tried logging in as the user that's normally broken, but using GNOME/Unity. And it worked! So presumably there's something clever GNOME is doing...? Will update the question with both. – Giles Thomas Jan 2 '17 at 23:40
  • Thanks for the update. Unfortunately I have no experience with qtile. Some ideas: Does qtile make use of pulseaudio at all? Is ALSA unmuted? Pulseaudio also excessively makes use of DBus. – Takkat Jan 3 '17 at 7:41
  • I don't think it's qtile specifically (perhaps I should try with a different lightweight WM like i3 and see if it repros) but that's an interesting point about DBus. GNOME uses it, and if pulseaudio uses it too but qtile doesn't, maybe I need to tweak my qtile startup to start it up. Time to start digging through GNOME's startup stuff, I guess :-S – Giles Thomas Jan 3 '17 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.