After the updatemanager gave me an update of the kernel from 3.0.0-13 to -14 i am not able to boot with that new kernel. I have to manually select -13 from older kernels.

This is even true for failsafe mode...

It shows the animated bootlogo and after 1 or 2 minutes the animation freezes, after that point the HDD-Light flashes randomly. I took a nap for an hour or so for one of the tryies, not even in this hughe timespan something happened.

With CTRL-ALT-DELETE I can still shut down the system, also it responds to the Power-Switch and shuts off, in both cases without any animation. I just see that the HDD-activity raises and after a further minute or two the System powers down.

RobinJ made a suggestion it could have something to do with my nVidia-drivers, so I followed his instructions (remove the nVidia-driver, reboot into old kernel, reboot into new kernel, reinstall driver). But removing the drivers did not help. The boot does still stuck, so I cant reinstall the driver in the new kernel.

But during the reboot process I managed to hit ESCAPE at the right point of time. The last message displayed before the boot stops is Checking battery state. So I tried to boot without AC-Adapter or battery, both does not help either, so I am back at kernel version -13 (still without the drivers)

Is there a way to get -14 working or at least have -13 standardkernel for booting until the problem is solved?

  • Have you got NVidia drivers installed?
    – RobinJ
    Dec 10, 2011 at 14:43
  • Yes. Version 280.13, no update offered so far.
    – NobbZ
    Dec 10, 2011 at 15:12
  • There's your problem I think :)
    – RobinJ
    Dec 10, 2011 at 16:23
  • 1
    You're supposed to boot in the the old kernel, remove the drivers, boot into the new kernel, install the drivers. You uninstalled the drivers while booting into the old kernel, and again booted into the old kernel, you missed one here. Dec 10, 2011 at 23:49

2 Answers 2


RobinJ's answer has worked for me. I booted to -13 and uninstalled nvidia drivers using Jockey. When booting -14, the boot halted on the same "Checking Battery Status" message.

I Ctrl+F1'd to a terminal and discovered that my /etc/X11/xorg.conf file still referenced the nvidia driver. To fix, I:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo reboot

Upon rebooting, Ubuntu ran correctly. I could then re-install the nvidia driver with Jockey.

  • This one worked for me, did not know that I can switch to a terminal this way during the boot...
    – NobbZ
    Dec 11, 2011 at 6:14

Go into the old kernel version (the one that still boots), and remove the NVidia drivers, preferably with Jockey (the Additional hardware drivers dialog).
Then reboot into the old kernel again (for safety's sake, I think it does something at the next boot when you remove the NVidia drivers).
Then, boot into the new kernel. If you had the same problem as I had when I updated the kernel then it should boot. You should now also be able to safely install the NVidia drivers again, just make sure you install them when running the newer kernel.

  • I tried your suggestion, but it does not help. I'll edit my question and add further information I just found out.
    – NobbZ
    Dec 10, 2011 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.