I installed windows 10 on an ssd with a ASRock X99 Extreme4 motherboard.

From windows, I shrank the windows partition to make space to dual boot ubuntu. I used Rufus 2.11 to create a usb with ubuntu 16.04.1.

The BIOS mode is “Legacy” and I’m getting the message about forcing UEFI. I take it that this happens when the usb media has one boot mode that is different from the computer’s BIOS.

I’ve recreating the usb using the three options for the partition scheme options in Rufus but continue to get the same message.

For Secure Boot, I’ve seen this post and get the result that Cmdlet not supported on this platform. That post suggests that

You can install Ubuntu by simply inserting the LiveCD or LiveUSB and doing the installation procedure without any problems.

First, am I correct about the problem and should not force UEFI? If so, how can I make the proper install media?

3 Answers 3


You first need to figure out whether Windows is booting in BIOS/CSM/legacy mode or in EFI/UEFI mode. See this page of mine for details, but basically, you can check the "BIOS mode" line in System Information; it should read "Legacy" or "UEFI," depending on the boot mode.

With the boot mode known, you need to create a bootable Ubuntu installation USB flash drive that includes the appropriate boot loader. Most (but not all) tools for turning Ubuntu .iso files into bootable USB media can create mediea with either (or both) BIOS-mode and EFI-mode boot loaders. Rufus is one of the more flexible of tools in this respect; it has three options for boot loader and partition table inclusions. See this page of mine for some more comments on this subject.

Note that installing Ubuntu in EFI mode when Windows is in BIOS mode, or vice-versa, is asking for trouble. Such cross-mode installations can work, but they require considerable expertise to set up.


For me Windows 10 was installed in Legacy mode. If you're ok with running both Windows and Linux in Legacy mode then this will hopefully work for you.

Check to see what mode Windows is in. I just looked at my system info, in the BIOS column. If you are fine with the default choice it is set in, reboot you computer and go into BIOS settings to view your bootable drives.

If you made a bootable USB/DVD with Rufus' default settings, (MBR BIOS and UEFI) there should be two versions of it visible in BIOS. One says the name of your USB "with UEFI". For me, that one that kept booting by default, so to install in legacy mode I had to select the other one that just says the name of your flash drive (legacy). You should choose the one that matches your Windows installation mode. This fixed it for me.

If you want to change the the default option you can search for a tutorial on how to do that.


I like to add to what Rod Smith said.

My mistake:
1. So I checked in windows and my BIOS Mode was legacy
2. When I made a bootable USB, I used Rufus. It's default option for Partition scheme and target system type is MBR partition scheme for BIOS or UEFI
3. [Important] So, when I restarted my PC, it had two options to boot from. One is with your bootable media in EFI mode and another is BIOS mode. In my case it booted from EFI mode automatically.

1. At the start-up, from BIOS I manually selected the BIOS mode for my bootable media. That's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.