2

I use the DejaVu Book (size 11) font a lot for a couple of years, mainly as my default programming font and since I updated to Xubuntu 16.04, I see that this font is displayed a lot differently (bigger and more cramped) than it used to. The code looks horrible. I tried to copy the fonts from the old version in all the folders that I could find them but nothing changed.

I attached a photo with the renderings in 14.04 (upper) and 16.04 (lower)

Resizing is not an option, 10 is too small and 12 is huge. Is a solution for this issue? Thank you

image link

  • 1
    You might install font-manager and look at the Metadata of DejaVu Sans Mono Book. Try to find out what file is installed (on my 16.04 desktop this looks like in your 14.04 image, but maybe some other software installed another version). You also might download the font from fontsquirrel and install via font-manager. – ridgy Jan 1 '17 at 17:27
  • Welcome to Ask Ubuntu! ;-) I can't see any difference between the upper and lower part of your example... – Fabby Jan 1 '17 at 17:41
  • @Fabby I envy you because of this :), I am used to customize all my fonts and colors and after a lot of years using this font for programming, I see every difference. You can compare the last 2 (Lorem Ipsum) letters on the texts, you have to see the difference, the latter is taller. – Taw Jan 1 '17 at 19:22
  • @ridgy Thanks a lot for your help, I managed to install the latest version of this font on both distros and they don't look the same at all. The 16.04 renders it taller, therefore I think that it is a Debian renderisation problem, not a font problem to be honest. tinypic.com/r/ev0sxl/9 – Taw Jan 1 '17 at 19:24
  • Here is a better image: postimg.org/image/8m4d3t6y7 – Taw Jan 1 '17 at 19:28
0

I've recently upgraded my Debian and this rendering difference have been driving me insane ever since.
After several hours of useless googling and tinkering, I was finally able to get previous behaviour.

You need to:

  1. go to your DE (I use KDE4/TDE) font settings and disable any alterations from system defaults;
  2. execute dpkg-reconfigure fontconfig-config, the menu will appear, advising you to not use autohinter with DejaVu family. Select "Autohinter".
  3. in the following menu disable subpixel rendering.

That's it.

You don't need to reboot: from now on, any launched application will render font in an old, "vertically condensed" style.

  • 1
    Thanks for your comment, I did not understand the "disable any alterations from system defaults". I have the defaults: Enable anti-alising, hinting slight, subpixel order RGB. This was default. Also when I run the command from point 2, I do not get any advise or "Autohinter", it just does nothing... – Taw Jul 25 '17 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.