Today I was working on some random stuff when suddenly windows asking me for password to my wifi connection. I had to miss-click something, as I was writing and window disappeared.
Now I can't connect to my main wifi router from my laptop. My network card:

Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01)

stopped to seeing it. It sees, however other networks and can connect to them (but they are not comfortable to work with, I need my main).
When I use external wifi adapter, it works fine (but more usb cables on the desk = more mess). I can connect my mobile phone too.
I have tried to connect through command line, but:

iwlist wlan0 scan

does not show up my wifi network.
I also tried

nmcli c up uuid <uuid>

but it gives only:

Error: Connection activation failed.

I've checked router settings, but didn't find anything wrong there - no MAC filtering or something like that.

rfkill list all
0: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no

EDIT: I tried restart laptop/router, but it didn't work.


It looks like the wifi card may not being detected, or other errors are happening with it. Please sesee this link specifically covering broadcom wifi cards to see about installing drivers and troubleshooting it. https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.