0

First I just want to say I am fairly new to linux and even newer to setting up a server, so please bear with me.

Ok so first I have a (small) issue while installing webmin which is here Error installing webmin on ubuntu 16.04 after fixing that everything worked fine and I was able to login to webmin no problem. After logging into webmin I wanted to install wordpress. After a google search I found I can install through virtualmin (which I believe is supposed to come with webmin?)

I tried to install virtualmin using

sudo /bin/sh install.sh

Which returned this

Displaying the last 15 lines of /root/virtualmin-install.log to help    troubleshoot this problem:
mysql-client is already the newest version (5.7.16-0ubuntu0.16.04.1).
mysql-common is already the newest version (5.7.16-0ubuntu0.16.04.1).
mysql-server is already the newest version (5.7.16-0ubuntu0.16.04.1).
ntpdate is already the newest version (1:4.2.8p4+dfsg-3ubuntu5.3).
openssl is already the newest version (1.0.2g-1ubuntu4.5).
apache2-suexec-custom is already the newest version (2.4.18-2ubuntu3.1).
clamav-testfiles is already the newest version (0.99.2+dfsg-    0ubuntu0.16.04.1).
libdbd-mysql-perl is already the newest version (4.033-1ubuntu0.1).
procmail-wrapper is already the newest version (1.0-2).
scponly is already the newest version (4.8-4).
usermin is already the newest version (1.701).
webmin is already the newest version (1.830).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
mysql-server : Depends: mysql-server-5.7 but it is not going to be installed
FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the     installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

I have tried doing 'apt-get -f install Which does not work. It's obvious the issue is with mysql so I tried

sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-core-5.5 mysql-client-core-5.5

which just tells me to try 'apt-get -f install'

Someone PLEASE help!

0

Starting from scratch, forget about webmin as a separate thing...

  1. you want to switch to your ubuntu root user ( "sudo su" hit enter, then "cd" and hit enter a second time to go back to root directory)
  2. Make sure its ubuntu 16 and apt-get update and apt-get upgrade are applied first.
  3. install "virtualmin gpl" using its automated installler (virtualmin gpl works perfectly with whmcs, you cannot add resellers is main restriction...just in case anyone is wondering)
  4. After virtualmin install is complete you can then add a new admin user in webmin and disable the root user login (so root still exists but cannot log into webmin or virtualmin). A mental note...virtualmin also has users..i selected the webmin tab and edited its users. I am not sure what difference it makes actually...webmin is running as root anyway. Perhaps its better to restrict access to admin to your home ipaddress instead (if you have purchased a static one from your home Internet Service Provider)...or force the use of an ssh tunnel for access???

I am no expert however i have found its best to use root user to install cpanels rather than using sudoer. Some panels specifically tell you to do install as root user (ispconfig and i think vestacp too) ....otherwise you end up with privilages and permissions problems after the install. I did the same for virtualmin install.

Webmin comes as part of the virtualmin gpl installer. You will have both at the end of automated install process and in addition to these two packages you get usermin included as well (although its not so obvious as there is no usermin tab like the clearly visible webmin and virtualmin ones on the dashboard screen).

Ensure you have only a blank operating system, more than 500MB RAM available on your virtual machine (preferrably 1 gig)

Make sure your hostname is configured, then add your external ip address to /etc/hosts . Add the following on line underneath existing localhost information (use your real ip address, hostname, domain) ( )

Other than that the automated installer should sort everything for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.