0

I'm trying to install the latest NVIDIA drivers for my GTX 965M Refresh on a Skylake board. I run Ubuntu MATE 16.04 with the stock kernel 4.4.0.

I added the graphics PPA. Now when I select any of the NVIDIA drivers under "additional drivers" in system settings, it does install them correctly, but the system won't boot anymore.

I tried 375.26, 370.28 and 367.57 with kernel 4.4.0, 4.4.39 and also 4.8 - same issue with all of them. The system freezes right after selecting a kernel in GRUB (blinking underscore cursor at the left top of the screen) and it doesn't write anything to syslog or kern.log that could help me figure out what the issue is about.

I disabled secure boot in BIOS. I use UEFI mode. I disabled the second onboard video card in the BIOS settings too, so that shouldn't be conflicting. And yes, I did purge nvidia-* several times before installing other drivers. I also tried manually setting nomodeset in my GRUB config, but no luck.

Any ideas how the heck I could debug this or what else I could try?

Update 1: I tried booting Manjaro in nonfree mode (which loads proprietary drivers automatically) from a pen drive and guess what? It works without issues and the card uses the nvidia driver. Manjaro currently uses Xorg 1.18.4 and kernel 4.4.x, (almost) same as Ubuntu 16.04. Now I know it's not related to the kernel version, the NVIDIA driver version, the xserver version, a BIOS setting or secure boot, but what the heck could it be related to then?

  • Disable Secure Boot in BIOS. – Pilot6 Jan 2 '17 at 10:21
  • I think you didn't read my message careful enough. Secure boot is disabled already and NVIDIA drivers work fine with Arch on the same system, so this is something related to Ubuntu (or just the MATE edition), I just can't seem to figure out what exactly. – John Wayne Jan 2 '17 at 11:54
  • Arch kernel does not enforce Secure Boot. – Pilot6 Jan 2 '17 at 12:22
  • Could you elaborate? If secure boot is disabled in BIOS, how can Ubuntu boot at all if it enforces secure boot? – John Wayne Jan 2 '17 at 15:49
  • Ubuntu is signed and it can boot. The Nvidia driver is not signed and it can't load with SB enabled. See askubuntu.com/questions/762254/… – Pilot6 Jan 2 '17 at 17:01
0

Solution: I ditched Ubuntu and its derivates and moved to Arch based distros. I chose Manjaro KDE to be specific and it works absolutely fine with my hardware running kernel 4.9 and latest NVIDIA drivers - no issues whatsoever. Goodbye Ubuntu.

Alternative Solution (possibly): Pretty much the only root cause that makes sense is that even though I had secure boot disabled in BIOS, it was still enabled somehow (BIOS bug or UEFI overriding BIOS settings, I don't know). Unfortunately I had already moved to Manjaro before I could try this solution (the mokutil one) which may or may not had solved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.