22

I own a Bluetooth headset (Sennheiser Momentum M2 AEBT). I am having an issue with autoconnection, for which I have found a workaround. I would prefer a real solution.

If I want the connection to work, I have to

  1. Connect the headset.
  2. Edit the Bluetooth settings, select audio profile "Headset Head Unit"
  3. Disconnect the headset.
  4. Connect the headset.
  5. Select "High fidelity playback" as the audio profile.

Then everything is peachy.

Here are alternate scenarios I've tried:

  1. When the headset and the computer autoconnect, the computer will use the most recent profile (High Fidelity Playback). However, VLC will play muted audio, and MPD will be persistently paused.

    If I try turning the profile to "off", then back to "High Fidelity Playback", I get the error message Failed to change the profile to a2dp_sink, and I see the same problems as before. The same situation occurs if I change the profile to "Headset Head Unit", then try switching to "High Fidelity Playback".

  2. You can see in the images that there are three options: "Headset", "Handsfree" and "Audio Sink". It does not seem to matter which one I click.

Here are screenshots with descriptions.

Available menu options in Bluetooth:

enter image description here

Persistent pausing in MPD. I can move forward or backward, but there is no "play" option:

enter image description here

VLC will happily play with no audio:

enter image description here

3
  • It's a problem with pulse audio – MathCubes Aug 9 '17 at 22:54
  • 1
    What version of Ubuntu are you using? And what Desktop Environment? – Spencer Hill Oct 10 '17 at 23:54
  • Do you still have this issue? If so, please edit the output of lspci and lsusb to your post. If not, please share your resolution with the community here. Thank you! – Elder Geek Dec 21 '17 at 14:29
1

The following solution worked for me:

  1. Check to see if the module-bluetooth-discover is loaded: pactl list short | grep blue If it's not in the list then:
  2. Load the module: pactl load-module module-bluetooth-discover

You might want to reload it even if it is in the list. Then, try to connect again to the audio sink for High Fidelity sound.

0

I've tried various proposed methods, but the only at least half-automatic solution for me was using the a2dp.py script as described already in this answer.

It does the steps mentioned in your question, but you have to run it each time you want to connect, and you need to pass a number to it to select the bluetooth device.

You could define a launcher (right-click on panel, select Panel Preferences...) which runs a small wrapper script to call a2dp.py and pass it the number of the bluetooth devices list that your headset typically has. For me, that number doesn't seem to change. Here my sample script run_a2dp.sh (adapt for your device number):

#!/bin/sh
# run a2dp.py and pass it a fixed device selection number
a2dp.py <<EOF
<your number here>
EOF

If you have both a2dp.py and this run_a2dp.sh on your $PATH, you can click the launcher whenever you want to connect with the headphones. It takes a few seconds for a2dp.py to finish the configuration, but it works for me.

At least no more fumbling around or running terminal commands to get it done...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.