0

I was running Ubuntu 16.04 with defaults (lightdm, Unity).

I desired to switch to Xubuntu, and did an apt install xubuntu-desktop, as well as apt-purge ubuntu-desktop unity-*.

I can log into XFCE now but I have several problems:

  • Xfce will not launch gnome-terminal as its default, even after setting it via update-alternatives

  • There's half a broken settings bar on the top with incomplete settings. If I access the proper Xfce settings from the left menu, those are fine.

screenshot

I don't know why this section of the top bar is differently colored, and it has a duplicate battery indicator, date/time, settings that don't quite work. How can I remove it?

Thanks.

edit

Those original problems are solved.

  • I was missing the apt auto-remove to clean up the old settings
  • Xfce has a settings page called "Preferred Applications" where I was able to set up gnome-terminal as the default
  • The little black section of the top bar is called the Indicator Panel, and it's a known issue that it doesn't match the regular color scheme

Now I have 2 other strange issues after a day of Xfce:

  • When I wake up from sleep, and start typing my unlock password, the screen will flash once, within a second of the unlock, and mess up the password I typed. I need to wait for the flicker to pass to type my password without errors

  • My keyboard doesn't work immediately after unlocking. I need to perform an action with my mouse. E.g. if I unlock and press Ctrl+Alt+T to launch the terminal, nothing happens. If I type in my browser to open a new tab, nothing happens. If I minimize a window with my mouse, then my keyboard starts working again.

  • Have you run update and upgrade commands? – user308164 Dec 31 '16 at 14:14
  • Actually it looks like autoremove fixed the top bar issue. But I haven't managed to get gnome-terminal to replace xfce-terminal yet. I can just create a different shortcut for it but I really want to know how to override TerminalEmulator – Sevag Dec 31 '16 at 14:18
  • Oops, totally missed the "Preferred Applications" option. – Sevag Dec 31 '16 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.