0

I'm going from Building a toolchain for use with eCos and I've got to the point where I'm configuring and building the tools for binutils:

./configure --target=arm-elf --prefix=../gnutools -v &> configure.out2
make -w all install &> make.out

but when I run the make, I get this error:

libtool: link: only absolute run-paths are allowed

It looks like libtool is trying to build the /bfd/libbfd.a library using an -rpath that doesn't exist:

libtool --mode=link gcc -W -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2  -o libopcodes.la -rpath ../gnutools/x86_64-unknown-linux-gnu/arm-elf/lib -release 2.13.1  dis-buf.lo disassemble.lo arm-dis.lo  

so to get around that I set and env var LIBDIR to the lib directory I assume its looking for:

LIBDIR=/home/dan/dev/arm/crosstool/gcc-4.0.1-glibc-2.3.5/arm-linux/arm-linux/lib

and run a bash script which calls libtool with the above parameters except -rpath is set to $LIBDIR and it makes the libbfd.a library fine. Then I run make and it gets to trying to make the library for the opcodes directory and has the same problem. How to I set the -rpath in the configure script? Or even set it by editing the Makefile?

  • In your ./configure you've got --prefix=../gnutools and shouldn't it be --prefix=/gnutools? It wants a absolute path, not ..relative. – heynnema Dec 31 '16 at 15:19
  • heynnema - that fixed it. I was doing my directories a little different than what the 'Building a toolchain..." page said. Now I'm having a different problem but I guess technically I have to start a new thread. – SpaceCowboy Dec 31 '16 at 15:57
0

In your ./configure you've got --prefix=../gnutools and it should be --prefix=/gnutools. It wants an absolute path, not ..relative.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.