1

I have been trying to encrypt my home directory using the instructions here: http://www.howtogeek.com/116032/how-to-encrypt-your-home-folder-after-installing-ubuntu/, but it failed part of the way through after running the command sudo ecryptfs-migrate-home -u eddy. Here are the last few lines output before the programme terminated:

android_workspace/MyFirstApp/src/com/eddytheb/myfirstapp/DisplayMessageActivity.java
      1,463 100%    4.91kB/s    0:00:00 (xfr#200443, to-chk=1/221932)
android_workspace/MyFirstApp/src/com/eddytheb/myfirstapp/MainActivity.java
      1,025 100%    3.34kB/s    0:00:00 (xfr#200444, to-chk=0/221932)
information/
preprobe/
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1183) [sender=3.1.1]

I've had a look for "previous errors", but I can't see anything, it looks to me like there's basically a line like the following for every file, but I cannot see back to the beginning of the command because it has filled my terminal as far back as I can scroll.

Pictures/2016/Photos2016Edited/IMG_20160720_124505.jpg
  2,118,107 100%    3.05MB/s    0:00:00 (xfr#197821, ir-chk=2133/221314)

So I'd like to know, did the encryption work? Did it work for some files, fail for others and then stop? And if it failed what can I do? Is it safe to just try running the command again or will that result in some double-encryption issues? Perhaps I should just recover from my recent backup before trying again.

MORE INfO

Other info that suggests that the process worked:

After sudo ecryptfs-migrate-home -u eddy failed I logged back in as eddy and two things happened that suggested something had changed: first, I was instructed to re-install dropbox; and second, I was instructed to view and make a note of my ecryptfs passphrase. I did both.

From my home directory ls -A /home shows that I have an .ecryptfs directory, and that /home/.ecryptfs/eddy/.Private/ is full of files like 'ECRYPTFS_FNEK_ENCRYPTED.FXbO-DbnsIQgsUSOhExSAtVeUT6iVjljYTA-ze4e4UzGGHP1E0fZajIdzrID0q-TjIKzj75kD4Y-Ga6-'

If I do df -T then I see that my home directory is mounted; I have a line that reads:

/home/.ecryptfs/eddy/.Private ecryptfs 957172372 454736500 453791216  51% /home/eddy

Other info that suggests that the process failed:

If I log out of eddy and log in as my temporary user with administrative rights, then sudo ls -lA /home/eddy/ shows my entire home directory. I was expecting just 4 files, as suggested by the answer to this question here: Check if partition is encrypted

1

A little bit of investigation, and I have confirmed that the encryption process worked. I created an Ubuntu boot usb drive, and booted my laptop from that, and when I tried to access the 'eddy' home directory it contained only the four items; Access-Your-Private-Data.desktop, .ecryptfs, .Private and README.txt. While if I looked in the home directory of another account then it contains all of the usual directories.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.