4

I am trying to allow anyone to log in as a guest and watch movies on my secondary hard drive. It used to be a Windows computer so the file format is NTFS. As I don't have a backup drive big enough to copy everything and change the file format, Im stuck with NTFS.

Here is the line of code in /etc/fstab I used to auto mount it:

UUID=5292DEBE92DEA5AF /media/exthd ntfs-3g users,permissions,auto 0 0

I also added this line to /etc/guest-session/prefs.sh so the guest account was added to the group guests that I created

adduser $USER guests

I then set the group of every file to guests and gave it all group and global read access.

Is it even possible to do what I am requesting?

Whenever the guest tries to get to the drive it give an error saying:

"This location could not be displayed. You do not have the permissions necessary to view the contents of "seconddrive"."

EDIT: I discovered that the issue has to do with apparmor in the lightdm-guest-session profile. I don't have much experience with apparmor. how would I know what in that profile is causing the issue?

3

Open /etc/apparmor.d/abstractions/lightdm for editing and find these lines:

  owner /{,run/}media/ r,
  owner /{,run/}media/** rmwlixk,  # we want access to USB sticks and the like

I think that dropping the owner part from those lines will make a difference (after next reboot). Note, though, that it means that you give the guest users access to all mounted devices, so you need to decide if that matters in your case.

Edit:

Also take a look here. It looks like the gid of the guests group needs to be included in the mount options.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.