I'm trying to install Linux to dual-boot with Windows on my 2016 Razer Blade Stealth. However I'm running into issues with every single distro I've tried. The only distros I've actually been able to successfully install are ubuntu variations (Ubuntu LTS 16.04 and Lubuntu 16.10). However with both of those variations I get this awful screen flickering issue (click the link to see a video of it).

A peculiar thing about the issue is that the screen does not flicker at all when my finger is on the trackpad (this is demonstrated in the video). Or when I'm running ubuntu and I have a secondary monitor connected. Also I do not experience this issue at all when running Windows.

jack@jack-Blade-Stealth:~$ sudo lshw -C display
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:276 memory:db000000-dbffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff
jack@jack-Blade-Stealth:~$ uname -a
Linux jack-Blade-Stealth 4.8.0-32-generic #34-Ubuntu SMP Tue Dec 13 14:30:43 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I believe it has something to do with the graphics drivers. I have Intel HD Graphics 620. I looked up downloads for drivers but the Intel site said that most distributions come pre-installed with intel graphics drivers. There were several packages I could install but I'm pretty new to Linux and I wasn't sure which package to download or how to use it.

Any advice would be much appreciated. Thank you.

  • Maybe try to use different kernel then the stock one. You can try at http://kernel.ubuntu.com/~kernel-ppa/mainline/ or even something like Liquorix https://liquorix.net/ – Michal Przybylowicz Jan 2 '17 at 4:24
  • 1
    This looks like a hardware problem (pressure in the trackpad area "solves" a loose contact. Get the hardware guide for your machine and re-seat the monitor connections and the GPU. – Fabby Jan 4 '17 at 3:17
  • if you are relying on the built in graphics you might want to try kernels newer than 3.6 . I would agree that this sounds like a hardware issue as well. screen flicker should only really be refresh rates or composition errors which would create logs entries in /var/log/Xorg.0.log . – Amias Jan 4 '17 at 14:41
  • While you are editing into your post the fact that you don't experience this problem under windows, please also include the output of sudo lshw -C display and uname -a as this information will undoubtedly be useful in determining what is going on. Thank you for helping us help you! – Elder Geek Jan 11 '17 at 20:54
  • I ran those commands and put them in the post as requested. I noticed that the display clock is at 33MHz. Could that be related to the issue? Thank you. – Snubber Jan 12 '17 at 19:27
  1. really new hardware requires newer software -> use 16.10
  2. it seems an issue related to PSR (panel self-refresh), try disable it -> https://wiki.archlinux.org/index.php/Intel_graphics#Screen_flickering
  3. since the issue seems video-related and you are using integrated one (intel), try to disable other features, such as power-saving one, if enabled by default -> https://wiki.archlinux.org/index.php/Intel_graphics

No need to upgrade to 16.10; 16.04 LTS is running the same kernel as 17.04. Download the Intel Linux Graphics Update Tool (version 2.02) and run that. They have extensive instructions on their webpage on how to do it. This will bring you completely up-to-date. After that, you can start to debug. FYI: I also have the screen flicker - it is likely an issue with the Ubuntu Kernel.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.