1

I'm using LXDE 0.5.0-4ubuntu4, and when I'm logged in to an LXDE desktop session, my USB drive won't automount upon plugin. If I unplug, log out, log in to a regular Ubuntu desktop session, and plug back in, it automounts just fine. But LXDE is my preferred GUI shell, and logging out is rarely feasible...

I went into PCManFM's Edit, Preferences menu, and under Volume Management I found that the "Mount removable media automatically when they are inserted" was already checked.

I'm capable of figuring out how to mount a drive from /dev/sdwhatever, but both fdisk -l and gparted say my only drive is /dev/nvem0n1p1, which is my primary drive. ls /dev/sd* does show a /dev/sda, but I'm not quite sure what that is.

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 008: ID 0781:5581 SanDisk Corp. Ultra
Bus 001 Device 004: ID 0c45:6713 Microdia 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

That SanDisk entry, that's my device.

Relevant dmesg excerpt:

[33081.244342] usb 1-2: new high-speed USB device number 8 using xhci_hcd
[33081.373412] usb 1-2: New USB device found, idVendor=0781, idProduct=5581
[33081.373416] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[33081.373418] usb 1-2: Product: Ultra
[33081.373420] usb 1-2: Manufacturer: SanDisk
[33081.373421] usb 1-2: SerialNumber: 4C531001331012120474
[33081.391323] usb-storage 1-2:1.0: USB Mass Storage device detected
[33081.391391] scsi host3: usb-storage 1-2:1.0
[33081.391471] usbcore: registered new interface driver usb-storage
[33081.393101] usbcore: registered new interface driver uas

How can I address this problem? What other diagnostic info can I gather?

2

There is actually a quite simple answer assuming you have pcmanfm the default file manager of lxde. Go to edit preferences volume management and check the boxes for auto mount that you want mount available volumes automatically on program startup and mount removable media automatically when inserted.

The last one is an optional preference of showing options in a file show available options for media as they are inserted. You may not want this in the corner case if you insert external hard drives with multiple partitions as it has a take an action dialog for each partition.

Pcmanfm should automatically be started as it draws the desktop wallpaper and icons in addition to being a file manager.

  • I had already ensured that that those boxes were checked, but due to your answer I took a second look at those Preferences anyways, and found my problem (see my answer), so thank you for this answer. – feuGene Dec 30 '16 at 20:55
1

The problem was with PCManFM's Preferences, but it had nothing to do with the automount-when-inserted checkbox.

It turns out that my USB drive came with some Windows software on it, and the Volume Management section of PCManFM's Preferences had a "Windows software" entry in the list labeled "Don't show available options for those media types:". I removed that item from the list, unplugged and replugged, and, voila!

Thanks to @ianorlin for making me take a second look at that Preferences dialog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.