3

I bought an SSD and wanted to replace my current HDD with that new SSD Here is what I did:

  1. Booted laptop from an ubuntu usb and Made an image of my current HDD using dd:

dd if=/dev/sda of=/mnt/external_drive/some/folder/hdd.img

  1. removed the current HDD from the laptop and put the new SSD in place
  2. Rebooted the laptop on my ubuntu usb
  3. USed dd to clone the image to the SSD

dd if=/dev/external_drive/some/folder/hdd.img of=/dev/sda

  1. Tried to reboot on my new ssd with no luck

I then tried to reboot on my USB flash drive and format my ssd and reinstall a fresh ubuntu on it but the drive is not visible in GPARTED or the BIOS . It is like it is not in computer.

  • SSD does not show up when using lsblk or GPARTED so impossible to format it or reinstall grub
  • BIOS does not detect SSD

Please help me recover my SSD

Thank you

  • 1
    If BIOS does not detect SSD how do you expect we help you? Please check whether or not such drive is supported by the motherboard before anything else. BTW, which laptop? Which SSD? Usually this info would be irrelevant but because it isn't being detected, now it is quite relevant. – user589808 Dec 30 '16 at 18:55
  • The new SSD was visible BEFORE I did the dd on it . It become not visible when I rebooted AFTER the dd – Charles-Eugene Loubao Dec 30 '16 at 18:57
  • DD does many things but it does NOT make a SSD not being detected in BIOS/UEFI, that's entirely hardware, period. Again, please indulge my curiosity and for the sake of completeness, add the request informations. – user589808 Dec 30 '16 at 19:02
  • I HAVE run into this problem before. Try wiggling the cable, etc. I don't recall how I fixed it unfortunately, but have had this exact same problem after dd-ing to an ssd and recovered from it by just playing around until I found it. – Kyle H Dec 30 '16 at 19:04
  • Your SSD was seen as a mass storage device, but after the cloning operations it is no longer seen. It means that it is probably severely damaged. Maybe there was a manufacturing defect, that made it break. Try to use the guarantee - to get it replaced with a new drive. But you should test it in another computer before going to the vendor. – sudodus Dec 30 '16 at 19:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.