5

I recently got a Bluetooth headset. It worked (more or less) for playing audio & such, but I am unable to use the microphone.

I have read that A2DP does not support audio input (?), and so I tried to switch to HSP/HFP. If I switch in pavucontrol, it has no effect. If I switch in the blueman devices menu, it simply says:

Failed to change profile to headset_head_unit

I am currently using a fresh install of Xubuntu 16.04.1

Any help would be appreciated!

Note: I have also noticed that I am missing /etc/bluetooth/audio.conf, don't know if that's a problem, and if so, how to I replace it..?

EDIT:

Here are the results from lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0eef:c0aa D-WAV Scientific Co., Ltd 
Bus 001 Device 005: ID 8087:0a2a Intel Corp. 
Bus 001 Device 004: ID 0bda:58c2 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 1058:1235 Western Digital Technologies, Inc. 
Bus 001 Device 002: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The bluetooth card is simply labelled "Intel Corporation Wireless 3165 (rev 79)" in lspci

8
  • What Bluetooth headset exactly?
    – user589808
    Dec 30, 2016 at 18:28
  • The brand is "Replay Audio". I have confirmed that it works on my iDevices and Windows PC just fine, so I doubt that its an issue with the headset. But you never know...
    – atoms118
    Dec 30, 2016 at 18:32
  • Did it ask for a PIN code when pairing? Some devices do not work in the HSP/HFP mode without it. BTW, it's "0000".
    – user589808
    Dec 30, 2016 at 18:36
  • It did not ask for a PIN, however, one of my other devices did ask for a PIN (And 0000 worked)...
    – atoms118
    Dec 30, 2016 at 18:37
  • Try deleting and pairing again but now, before confirming, explicitly change the device type accordingly.
    – user589808
    Dec 30, 2016 at 18:51

1 Answer 1

2

A solution seems to be worked on (I hope), I've been following this bug report on Launchpad, but hasn't been very active.

If a solution comes about I'll update my answer.

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1549163

UPDATE 6/03/17 The bug was given has fixed. I suppose we just have to wait until we receive an update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .