1
RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful.
Executing'/sbin/vboxconfig' may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 ERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user

dpkg --list | grep virtualbox

ii  unity-scope-virtualbox  0.1+13.10.20130723-0ubuntu1 all VirtualBox scope for Unity
ii  virtualbox-5.1:i386 5.1.12-112440~Ubuntu~xenial i386 Oracle VM VirtualBox

Already tried solutions from link VirtualBox kernel modules do not match the version of VirtualBox

my secure boot is also disabled.

1

The issue here is the that:

  1. The official Virtualbox in the Ubuntu repo is usually older than the one you install from the official Virtualbox download page.
  2. If you have to install [a newer version] from a different source, then you have to :
    • uninstall the one that comes from Ubuntu repo and this should be done with the command sudo apt remove --purge so that the virtualbox kernel modules will also be removed.
  3. Then download the latest for your Ubuntu version and simply install and it will be build new virtualbox kernel modules that will match your virtualbox version.
  4. If you don't need the latest version then simply install with:

    sudo apt install virtualbox
    

The steps stated here in your included link will still work.

0

i rebooted the pc unistalled virtual box. sudo apt-get purge virtualbox-5.1:i386 then reinstalled a previous version and it worked succesfully

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.