15

This question already has an answer here:

Network Manager reports:

device not managed

Output of sudo lshw -C Network:

*-network DISABLED        
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 15
   serial: 2c:60:0c:f6:97:a6
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.042.00-NAPI duplex=full latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
   resources: irq:47 ioport:4000(size=256) memory:c4404000-c4404fff memory:c4400000-c4403fff
*-network
   description: Wireless interface
   product: QCA9377 802.11ac Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 30
   serial: 48:e2:44:46:07:ab
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath10k_pci driverversion=4.8.0-34-generic firmware=WLAN.TF.1.0-00267-1 ip=192.168.1.101 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:53 memory:c4200000-c43fffff

Output of nmcli d:

DEVICE  TYPE      STATE      CONNECTION             
wlp3s0  wifi      connected  FASTWEB*************** 
enp2s0  ethernet  unmanaged  --                     
lo      loopback  unmanaged  --   

Output of ifconfig:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 2487  bytes 383935 (383.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2487  bytes 383935 (383.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.101  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2001:b07:6452:4630:d631:dc14:aa32:46e7  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::7932:6d1f:e49b:9b8d  prefixlen 64  scopeid 0x20<link>
        ether 48:e2:44:46:07:ab  txqueuelen 1000  (Ethernet)
        RX packets 29742  bytes 30300740 (30.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22589  bytes 4019841 (4.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Output of ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 2c:60:0c:f6:97:a6 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 48:e2:44:46:07:ab brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.101/24 brd 192.168.1.255 scope global dynamic wlp3s0
       valid_lft 42392sec preferred_lft 42392sec
    inet6 2001:b07:6452:4630:d631:dc14:aa32:46e7/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::7932:6d1f:e49b:9b8d/64 scope link 
       valid_lft forever preferred_lft forever

How do I fix this?

marked as duplicate by jokerdino Apr 18 '17 at 8:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What does this report? cat /etc/network/interfaces? Welcome to Ask Ubuntu. – chili555 Dec 29 '16 at 21:43
31

Run this in the terminal (then reboot):

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

It fixed a similar issue when I upgraded Ubuntu from 16.04 to 16.10.

  • it works! thank you very much... – Carlo Gandolfo Mar 29 '17 at 12:59
  • Well done, 'touch' for the win. – andy.holmes Apr 4 '17 at 14:00
  • Should be sudo touch ... no? – Raffi Khatchadourian Apr 17 '17 at 19:40
  • 2
    Worked for me as well - anybody knows why this "fix" works? An empty file fixes the network manager, is someone pulling my leg? – Piotr Kolaczkowski May 8 '17 at 13:04
  • 3
    Also worked on Upgrade from 16.04 to 17.04 – snitko Aug 7 '17 at 16:27
4

Your device exists, but the system is refusing to manage it for whatever reason.

To resolve this, make sure that your /etc/network/interfaces file does not contain a definition for your Ethernet device. In a terminal, run the following commands:

sudo cp /etc/network/interfaces /etc/network/interfaces.bak
sudo nano /etc/network/interfaces

Delete all lines but these three (unless you have a very good reason to leave other lines in there):

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Then, restart the Network Manager by either rebooting, or running the below command:

sudo service network-manager restart

Alternatively, you can enable management of all interfaces by Network Manager, but do note that this may cause other network-related issues.

In /etc/NetworkManager/NetworkManager.conf, change any line that says managed=false to this:

managed=true

Be sure to restart NetworkManager by rebooting or using the above command.

4

Try this link it explains the bug https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1638842

Not the answer you're looking for? Browse other questions tagged or ask your own question.