4

I am installing Ubuntu 16.04 server on a new HPE ML150 hardware. After the installation finishes copying files it prompts for installing additional software.

Software selection

What ever I choose at this step, the installation reports failure and prompts me to choose which step of installation to continue from.

enter image description here

Note that I was installing from a USB which I created using Startup Disk Creator in Ubuntu desktop.

Looking at the virtual terminal during this step, it seems that it is trying to get the packages from the CD-ROM rather from the internet. I assume that the internet connection works because in a previous step where it tries to figure the timezone by connecting on a timeserver, works fine.

4
  • 1
    Please show us the error message too!
    – guntbert
    Dec 29 '16 at 19:48
  • 1
    To see the real reason it often helps to switch to the one virtual terminal that contains the logs - try <ALT><LEFT> as often as needed.
    – guntbert
    Dec 29 '16 at 19:50
  • You are right. Tomorrow when I have access to the server. It will a picture though!
    – Demetris
    Dec 29 '16 at 19:50
  • I have added the failing screen of the installation.
    – Demetris
    Dec 30 '16 at 8:05
4
  • Press Alt+F2 to enter the BusyBox shell
  • Change directory to /target/etc/apt:

    cd /target/etc/apt
    
  • Copy sources.list.apt-setup to sources.list:

    cp sources.list.apt-setup sources.list
    
  • Edit sources.list:

    nano sources.list
    

    Comment out the line beginning with deb cdrom so it looks like this:

    # deb cdrom:[Ubuntu-...
    
  • Upgrade packages:

    chroot /target apt-get update
    chroot /target apt-get upgrade
    
  • Press Alt+F1 to return to the installer, and start Software Selection

6
  • 1
    Welcome to Ask Ubuntu! Whilst this may answer the question it is not quite clear what those commands do. Please elaborate your answer adding explanations.
    – dessert
    Nov 26 '17 at 10:36
  • @klaus. As I cannot test this (the server is up and working) I am not able to accept your answer yet. If anyone has this problem and this answer solves it, please comment here so I can accept this answer.
    – Demetris
    Nov 27 '17 at 9:34
  • 1
    @Demetris this worked for me. Also, the line to comment out is deb cdrom:[Ubuntu-Server.... One can use ´nano´ to edit the file (ctrk+o to save, ctrl+x to exit).
    – hinneLinks
    Dec 9 '17 at 15:20
  • I thought I was dead until I tried your solution. It worked great. I edited your answer to correct a file name and add the exact commands for newbies, but your answer is pure gold! Thank you so much! Jul 9 '18 at 23:42
  • I suspect it might be better to move the deb cdrom line to the end of the file rather than deleting it entirely. This way packages that exist only on the install disk can be found. Jul 11 '18 at 17:34
0

If you just want to finish your current installation, see @klaus' superb answer. If you want to fix the install disk so this no longer happens in future installations:

  • Press Alt+F2 to enter the BusyBox shell
  • View the installation log. You will be interested in the end of the file:

    tail -50 /var/log/syslog
    

This reveals that when I created the install disk, I removed a required package version:

Jul 11 00:42:19 in-target: The following packages have unmet dependencies:
Jul 11 00:42:19 in-target: perl : Depends: perl-base (= 5.22.1-9ubuntu0.2) but 5.22.1-9ubuntu0.5 to be installed
Jul 11 00:42:19 in-target: E: Unable to correct problems, you have held broken packages
Jul 11 00:42:19 in-target: tasksel: apt-get failed (100):Configuring pkgsel' failed with error code 1
Jul 11 00:42:19 main-memu [2511 WARNING:
Jul 11 00:42:19 main-menu [2511: WARNING: Menu item 'pkgsel' failed with error code 1

The installer found the package on the install disk, but it was the wrong version. Once I corrected this in my install disk creation script, the installation succeeded.

Not the answer you're looking for? Browse other questions tagged or ask your own question.