3

I have a AsRock motherboard with Realtek ALC892 chipset.

cat /proc/asound/cards

returns

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7110000 irq 29  
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17

The main thing is that I don't really hear bass on Audacious when playing music. If there's bass, is really low compared with Windows. I've tried loading a Bass and Treble preset from WinAmp using the Equalizer in Audacious and the sound is very bad, like when having a poor speaker on max volume. This happens both on my 2.0 setup or on my headphones.

How can I improve this?

1
  • what motherboard exactly ? When its brand-new, then generally with Linux it lasts 4 to 6 months until it is fully supported by drivers. – dschinn1001 Jan 25 '17 at 12:38
2

PulseAudio and ALSA are configured for 44.1KHz 16-bit audio by default which is not bad but not really great.

You can check the current configuration with:

$ pacmd list-sinks | grep sample

It will show something like this:

$ pacmd list-sinks | grep sample
sample spec: s16le 2ch 41000Hz
sample spec: s16le 2ch 41000Hz

To change it, we need to edit the PulseAudio's configuration file:

$ nano /etc/pulse/daemon.conf

Find these in the file:

; resample-method = speex-float-1
; default-sample-format = s16le
; default-sample-rate = 44100

Remove the semicolon and change the values to:

resample-method = src-sinc-medium-quality
default-sample-format = s24le
default-sample-rate = 96000

Save the file by pressing Ctrl+O (to save) and Ctrl+X (to exit).

Restart PulseAudio:

$ pulseaudio -k
$ pulseaudio --start

Check the settings again:

$ pacmd list-sinks | grep sample

It should something like this:

$ pacmd list-sinks | grep sample
sample spec: s32le 2ch 96000Hz
sample spec: s32le 2ch 96000Hz

and we are done!

For more info: https://r3dux.org/2013/12/how-to-enable-high-quality-audio-in-linux/

1
  • After doing this, only one of my "sample specs" changed. They other still has the default values. And there is still like no bass at all, compared to windows. Please help – Simon Sondrup Kristensen Dec 31 '18 at 14:36
0

Is amarok and rhythmbox installed on your system ? You should install them both, because these packages have drivers.

sudo apt-get install amarok rhythmbox

After this then, when playing music-files, there should be something to hear for you.

2
  • @Alin - reboot your machine then. – dschinn1001 Jan 21 '17 at 11:53
  • 1
    stil the same... I guess it's time to switch to Windows – Alin Jan 24 '17 at 12:41
0

Check that the system volume ist unamplified.

To do so, click on the speaker icon in the top panel and navigate to "Sound Settings" and set the slider to "unamplified".

It is also possible that parts of your sound system are muted or turned down, to fix this follow this tutorial.


If this doesn't help

You can try to enable High Quality Audio on Ubuntu by following these instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.