3

I've recently bought Dell inspiron and immediately installed ubuntu on it and pretty quick ran into a problem with the touchpad. Slightest touch moves the pointer away and I start typing somewhere I don't even expect. You can imagine how annoying and frustrating that can be. After some googling I found some settings I can play with, namely xinput and synclient. But thing is those settings seem to not to give any effect. I made a startup script

#!/bin/bash

xinput --set-prop 12 "Synaptics Palm Detection" 1
xinput --set-prop 12 "Synaptics Palm Dimensions" 5 80
xinput --set-prop 12 "Synaptics Locked Drags" 1
xinput --set-prop 12 "Synaptics Locked Drags Timeout" 500
syndaemon -i 1 -K -d

but it doesn't do much. Weird thing, I noticed that "Locked Drags" and "Locked Drags Timeout" options work just fine. But "Palm Detection" and syndaemon one don't work. Hell with the Palm Detection, but syndaemon -i 1 -K -d could solve everything if worked. I also noticed that when I list out input devices via xinput --list I get two touchpads. Maybe something's related to that?

$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=11   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=16   [slave  pointer  (2)]
⎜   ↳ DELL0741:00 06CB:7E7E Touchpad            id=12   [slave  pointer  (2)]

Anyways, I'd really appreciate if anyone could point me in right direction.

PS: please let me know if some more info is required on my end.

Thanks.

  • My Lenovo laptop had the same problem. Filing a bug report because that level of regression is really unacceptable. – Jeremy List Jul 16 '17 at 3:36
  • If 12 doesn't do anything, you need to use 16 or you should disable 16 so that you can use 12 instead. Have you tried this? – mchid Feb 13 '18 at 1:17
5

I ran in to the same issue after upgrading from 16.04 LTS to 16.10. Reinstalling xserver-xorg-input-all did the trick.

sudo apt install --reinstall xserver-xorg-input-all

My first attempt at reinstalling only xserver-xorg-input-synaptics fixed the issue with the touchpad but broke the keyboard input (on screen keyboard to the rescue).

This was on a Dell XPS 13 9350.

  • Thanks. I'll try it out, although I kinda learned how to live with it :D Like with external keyboard and touchpad. Whole new problems over there too, but that's a different story. Gotta love linux. – Kaster Mar 19 '17 at 21:57
  • Thanks! I was about to permanently abandon Ubuntu when I found your answer. – Jeremy List Jul 16 '17 at 3:32
4

The easiest way is to install libinput. It is a new user space touchpad driver where there is another palm detection algorithm that is more reliable.

Run in terminal

sudo apt install xserver-xorg-input-libinput

and reboot.

You will also need to enable tapping manually in /usr/share/X11/xorg-conf.d/90-libinput.conf.

  • Thanks. Played little bit with it. At first glance it solve the issue with the palm detection. But it just feels weird on small pointer movements. Like it was less sensitive to small displacements. Also, couldn't set up kinetic/inertial scrolling. I think it's must have on modern computers. Rolled back to synaptic. – Kaster Dec 29 '16 at 10:56
  • Inertial scrolling will never be implemented in libinput. It does not matter how modern a computer is. – Pilot6 Dec 29 '16 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.