0

I'm using Ubuntu 16.04 on my Macbook pro.

I need help getting write access to my Mac HD from Ubuntu. I can view and open the files in my Mac HD but I cannot write to the Mac HD. The options for "New folder" or "paste" are just grayed out when I'm in the Mac HD.

I have already gone into OS X and disabled journaling but no luck.

EDIT 1: A full history;

When I first installed Ubuntu, I couldn't get ANY access to my Mac HD although I could see it on my "Files" application. I looked up some online solutions and tried this;

  1. sudo apt-get install hfsprogs (install hfs programs into linux)
  2. sudo mount -o force /dev/sdX /your/mount/point (not sure what this is)
  3. sudo mount -o remount,rw,force /mount/point (remount )

...this didnt help.

what worked for me was;

  1. sudo useradd -d /home/tempuser -m -s /bin/bash -G admin tempuser (create a temp user on Linux)
  2. sudo passwd tempuser (setup passwor for new user)

Reboot and log in as tempuser. Then, open up the Terminal and type in the following commands;

  1. sudo usermod --uid 502 myusername( match my Ubuntu UID with that of OS X )
  2. sudo chown -R 502:myusername /home/myusername(no idea what this does)

....but after all this, although I could now access the Mac HD, it remains read only access until now.

  • You might want to test this command sudo mount -o remount,rw /partition/identifier /mount/point – GreggD Dec 29 '16 at 8:11
  • I have just tried that I got "mount: /dev/sda2 not mounted or bad option In some cases useful info is found in syslog - try dmesg | tail or so." – Francis part 2 Dec 29 '16 at 9:30
  • Never never never do a command in terminal, especially if it starts with sudo, unless you know exactly what it does first. – heynnema Dec 29 '16 at 19:40
1

Have a look at Super User

Disabling journaling from HFS+ is supported until OS X Yosemite 10.10

install hfsprogs sudo apt-get install hfsprogs

then mount sudo mount -t hfsplus -o force,rw /dev/sdx# /media/mntpoint or remount sudo mount -t hfsplus -o remount,force,rw /dev/sdx# /mount/point

To fix improperly unmounted:

sudo fsck.hfsplus /dev/sdx#

EDIT:

After seeing the updated question,you should do:

sudo chmod -R +rw myusername /home/myusername

  • I had already done the hfsprogs thing to get access to the Mac HD, I retried when you asked me but nothing new....I also just tried "fsck" and I got ** /dev/sda2 ** Checking HFS Plus volume. ** Checking Extents Overflow file. ** Checking Catalog file. ** Checking multi-linked files. ** Checking Catalog hierarchy. ** Checking Extended Attributes file. ** Checking volume bitmap. ** Checking volume information. ** The volume Macintosh HD appears to be OK. – Francis part 2 Dec 29 '16 at 9:35
  • 1
    @Francispart2, please add the steps you have taken to your post so those don't get re-suggested to you. – George Udosen Dec 29 '16 at 9:40
  • do as George suggested,add to your questions what you have done already and the output – Arduino_Sentinel Dec 29 '16 at 10:07
  • Ok I have edited my question and I have added the full history of my exploits. – Francis part 2 Dec 29 '16 at 12:19
  • from the setups you have shown,then give permission to write access like sudo chmod -R +rw myusername /home/myusername – Arduino_Sentinel Dec 29 '16 at 14:40
1

Your hard disk may have a problem, and then gets placed into read-only mode.

Lets first check the file system for errors...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery Mode
  • choose root access
  • type sudo fsck -f /
  • run fsck more than once if there were errors
  • type reboot

Then lets check the disk hardware...

  • start the Disks app from the Unity dash
  • select the target disk in the left pane
  • click on the "hamburger" icon located at the top-right of the Disks window
  • select SMART Data & Tests
  • review the data, run the tests
0

This is weird but I think I will now answer my own question!...for those who might have the same problem in future.

After messing around trying to implement heynnema's solution, I noticed that my mount options in "Disks" were set to "ro". Even my basic computer knowledge could recognise that meant read only, so(after a bit more research), I deleted the "ro" and bobs your uncle, I now have full access to my Mac HD.

All that was needed was to remove "ro" from "nosuid,nodev,nofail,x-gvfs-show,ro,x-udisks-auth" in the mount options of my Mac partition. I think this is what you might have been suggesting Arduino.

Thanks to ever so much to all of you that responded...Now I just need to find out how to add shortcuts to the contents of my Mac disk onto my Ubuntu desktop!

  • Oh! You meant r/w access to your "Mac HD" partition from Ubuntu. The way your question reads I took "Mac HD" to mean disk. I thought that your Ubuntu root was r/o. – heynnema Dec 30 '16 at 15:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.